aboutsummaryrefslogtreecommitdiffstats
path: root/package/6to4/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-11-14 23:51:16 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-11-14 23:51:16 +0000
commit5630b34f4aa114e3f0d0c65e6bd31bc53a26ae03 (patch)
tree987ea54c53572cf4d69242faf44d8c33b61c1dbd /package/6to4/Makefile
parentad1f4fa94dfc0c4822fd6be7f4d4be67aa758c3a (diff)
downloadupstream-5630b34f4aa114e3f0d0c65e6bd31bc53a26ae03.tar.gz
upstream-5630b34f4aa114e3f0d0c65e6bd31bc53a26ae03.tar.bz2
upstream-5630b34f4aa114e3f0d0c65e6bd31bc53a26ae03.zip
[package] add 6to4 - provides full automatic 6to setup with optional configuration in /etc/config/network
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23996 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/6to4/Makefile')
-rw-r--r--package/6to4/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/package/6to4/Makefile b/package/6to4/Makefile
new file mode 100644
index 0000000000..cf9f74136b
--- /dev/null
+++ b/package/6to4/Makefile
@@ -0,0 +1,44 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=6to4
+PKG_VERSION:=1
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/6to4
+ SECTION:=ipv6
+ CATEGORY:=IPv6
+ DEPENDS:=+ip +kmod-ipv6 +kmod-sit
+ TITLE:=IPv6-to-IPv4 configuration support
+ MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
+ PKGARCH:=all
+endef
+
+define Package/6to4/description
+Provides support for 6to4 tunnels in /etc/config/network.
+Refer to http://wiki.openwrt.org/doc/uci/network for
+configuration details.
+endef
+
+define Build/Compile
+endef
+
+define Build/Configure
+endef
+
+define Package/6to4/install
+ $(INSTALL_DIR) $(1)/lib/network
+ $(INSTALL_DATA) ./files/6to4.sh $(1)/lib/network/6to4.sh
+ $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+ $(INSTALL_DATA) ./files/6to4.hotplug $(1)/etc/hotplug.d/iface/91-6to4
+endef
+
+$(eval $(call BuildPackage,6to4))