aboutsummaryrefslogtreecommitdiffstats
path: root/package/6in4
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-07-09 00:17:31 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-07-09 00:17:31 +0000
commited4240b1c3f93cb88db03ec6f8ef12b83a975190 (patch)
tree2738e2e1e3eeb1d0af1994e125dd65564e71bb19 /package/6in4
parent7c5114a298cfeb6670c03b3bf17b9cac5bbeb277 (diff)
downloadupstream-ed4240b1c3f93cb88db03ec6f8ef12b83a975190.tar.gz
upstream-ed4240b1c3f93cb88db03ec6f8ef12b83a975190.tar.bz2
upstream-ed4240b1c3f93cb88db03ec6f8ef12b83a975190.zip
[package] 6in4: automatically determine wan interface in hotplug events
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22102 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/6in4')
-rw-r--r--package/6in4/Makefile2
-rw-r--r--package/6in4/files/6in4.hotplug2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/6in4/Makefile b/package/6in4/Makefile
index d88ee16066..75e7848825 100644
--- a/package/6in4/Makefile
+++ b/package/6in4/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=6in4
-PKG_VERSION:=2
+PKG_VERSION:=3
PKG_RELEASE:=1
include $(INCLUDE_DIR)/package.mk
diff --git a/package/6in4/files/6in4.hotplug b/package/6in4/files/6in4.hotplug
index 0a196c25b0..96b046d14d 100644
--- a/package/6in4/files/6in4.hotplug
+++ b/package/6in4/files/6in4.hotplug
@@ -14,7 +14,7 @@ if [ "$ACTION" = ifup ]; then
[ "$proto" = 6in4 ] || return 0
local wandev
- config_get wandev "$cfg" wan_device
+ config_get wandev "$cfg" wan_device "$(find_6in4_wanif)"
[ "$wandev" = "$DEVICE" ] || return 0
local oldip