aboutsummaryrefslogtreecommitdiffstats
path: root/package/6in4
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-09-11 18:58:17 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-09-11 18:58:17 +0000
commit7a479f7cc1748820d67d94c650cf827b1670bc19 (patch)
tree5df437eb780076e8b45b36e7c576fb350dfb894d /package/6in4
parente19163501ed1d15af047ea8d1b4a4fb40b6e522d (diff)
downloadupstream-7a479f7cc1748820d67d94c650cf827b1670bc19.tar.gz
upstream-7a479f7cc1748820d67d94c650cf827b1670bc19.tar.bz2
upstream-7a479f7cc1748820d67d94c650cf827b1670bc19.zip
[package] 6in4: don't use abbreviated notation for 0.0.0.0/0, iproute apparently does not like it anymore
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23022 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/6in4')
-rw-r--r--package/6in4/Makefile4
-rwxr-xr-xpackage/6in4/files/6in4.sh2
2 files changed, 3 insertions, 3 deletions
diff --git a/package/6in4/Makefile b/package/6in4/Makefile
index b9fa220df7..5722a48638 100644
--- a/package/6in4/Makefile
+++ b/package/6in4/Makefile
@@ -8,8 +8,8 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=6in4
-PKG_VERSION:=5
-PKG_RELEASE:=2
+PKG_VERSION:=6
+PKG_RELEASE:=1
include $(INCLUDE_DIR)/package.mk
diff --git a/package/6in4/files/6in4.sh b/package/6in4/files/6in4.sh
index 62a60dc8f6..2af1f74b29 100755
--- a/package/6in4/files/6in4.sh
+++ b/package/6in4/files/6in4.sh
@@ -2,7 +2,7 @@
# Copyright (c) 2010 OpenWrt.org
find_6in4_wanif() {
- local if=$(ip -4 r l e 0/0); if="${if#default* dev }"; if="${if%% *}"
+ local if=$(ip -4 r l e 0.0.0.0/0); if="${if#default* dev }"; if="${if%% *}"
[ -n "$if" ] && grep -qs "^ *$if:" /proc/net/dev && echo "$if"
}