aboutsummaryrefslogtreecommitdiffstats
path: root/package/6in4
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-05-29 12:59:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-05-29 12:59:07 +0000
commit71740064afcfbcf2ec8b7c03e5ff10e3d0f6c993 (patch)
tree55cf8113ab32c47d4e6a59b9a9331ab391a97668 /package/6in4
parenta15cc8b08990d6ee25ab0ed80c67b940b797a9f2 (diff)
downloadupstream-71740064afcfbcf2ec8b7c03e5ff10e3d0f6c993.tar.gz
upstream-71740064afcfbcf2ec8b7c03e5ff10e3d0f6c993.tar.bz2
upstream-71740064afcfbcf2ec8b7c03e5ff10e3d0f6c993.zip
6in4: remove old network scripts
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31981 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/6in4')
-rw-r--r--package/6in4/Makefile15
-rw-r--r--package/6in4/files.old/6in4.hotplug68
-rwxr-xr-xpackage/6in4/files.old/6in4.sh104
3 files changed, 2 insertions, 185 deletions
diff --git a/package/6in4/Makefile b/package/6in4/Makefile
index c2fcc3ba1c..60c1bcc2ac 100644
--- a/package/6in4/Makefile
+++ b/package/6in4/Makefile
@@ -11,8 +11,6 @@ PKG_NAME:=6in4
PKG_VERSION:=10
PKG_RELEASE:=1
-PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_netifd
-
include $(INCLUDE_DIR)/package.mk
define Package/6in4
@@ -36,20 +34,11 @@ endef
define Build/Configure
endef
-ifneq ($(CONFIG_PACKAGE_netifd),)
- define Package/6in4/install
+define Package/6in4/install
$(INSTALL_DIR) $(1)/lib/netifd/proto
$(INSTALL_BIN) ./files/6in4.sh $(1)/lib/netifd/proto/6in4.sh
$(INSTALL_DIR) $(1)/etc/hotplug.d/iface
$(INSTALL_DATA) ./files/6in4.hotplug $(1)/etc/hotplug.d/iface/90-6in4
- endef
-else
- define Package/6in4/install
- $(INSTALL_DIR) $(1)/lib/network
- $(INSTALL_DATA) ./files.old/6in4.sh $(1)/lib/network/6in4.sh
- $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
- $(INSTALL_DATA) ./files.old/6in4.hotplug $(1)/etc/hotplug.d/iface/90-6in4
- endef
-endif
+endef
$(eval $(call BuildPackage,6in4))
diff --git a/package/6in4/files.old/6in4.hotplug b/package/6in4/files.old/6in4.hotplug
deleted file mode 100644
index 3d9def448e..0000000000
--- a/package/6in4/files.old/6in4.hotplug
+++ /dev/null
@@ -1,68 +0,0 @@
-#!/bin/sh
-
-if [ "$ACTION" = ifup ]; then
- . /etc/functions.sh
-
- include /lib/network
- scan_interfaces
-
- update_tunnel() {
- local cfg="$1"
-
- local proto
- config_get proto "$cfg" proto
- [ "$proto" = 6in4 ] || return 0
-
- local wandev
- config_get wandev "$cfg" wan_device "$(find_6in4_wanif)"
- [ "$wandev" = "$DEVICE" ] || return 0
-
- local wanip=$(find_6in4_wanip "$wandev")
-
- [ -n "$wanip" ] && {
- lsmod | grep -q ^sit || {
- logger -t 6in4-update "Tunneling driver not loaded yet, deferring action"
- exit 0
- }
-
- local tunnelid
- config_get tunnelid "$cfg" tunnelid
-
- local username
- config_get username "$cfg" username
-
- local password
- config_get password "$cfg" password
-
- uci_set_state network "$cfg" ipaddr "$wanip"
-
- [ -n "$tunnelid" ] && [ -n "$username" ] && [ -n "$password" ] && {
- [ "${#password}" == 32 -a -z "${password//[a-fA-F0-9]/}" ] || {
- password="$(echo -n "$password" | md5sum)"; password="${password%% *}"
- }
-
- (
- local url="http://ipv4.tunnelbroker.net/ipv4_end.php?ip=AUTO&apikey=$username&pass=$password&tid=$tunnelid"
- local try=0
- local max=3
-
- while [ $((++try)) -le $max ]; do
- wget -qO/dev/null "$url" 2>/dev/null && {
- logger -t 6in4-update "Updated tunnel #$tunnelid endpoint to $wanip"
- ifup "$cfg"
- break
- } || {
- logger -t 6in4-update "Try $try/$max failed, retrying"
- sleep 1
- }
- done
- )&
- } || {
- logger -t 6in4-update "Re-establishing tunnel due to change on $INTERFACE ($DEVICE)"
- ifup "$cfg" &
- }
- }
- }
-
- config_foreach update_tunnel interface
-fi
diff --git a/package/6in4/files.old/6in4.sh b/package/6in4/files.old/6in4.sh
deleted file mode 100755
index 5f8dfffe57..0000000000
--- a/package/6in4/files.old/6in4.sh
+++ /dev/null
@@ -1,104 +0,0 @@
-# 6in4.sh - IPv6-in-IPv4 tunnel backend
-# Copyright (c) 2010 OpenWrt.org
-
-find_6in4_wanif() {
- local if=$(ip -4 r l e 0.0.0.0/0); if="${if#default* dev }"; if="${if%% *}"
- [ -n "$if" ] && grep -qs "^ *$if:" /proc/net/dev && echo "$if"
-}
-
-find_6in4_wanip() {
- local ip=$(ip -4 a s dev "$1"); ip="${ip#*inet }"
- echo "${ip%%[^0-9.]*}"
-}
-
-# Hook into scan_interfaces() to synthesize a .device option
-# This is needed for /sbin/ifup to properly dispatch control
-# to setup_interface_6in4() even if no .ifname is set in
-# the configuration.
-scan_6in4() {
- config_set "$1" device "6in4-$1"
-}
-
-coldplug_interface_6in4() {
- setup_interface_6in4 "6in4-$1" "$1"
-}
-
-setup_interface_6in4() {
- local iface="$1"
- local cfg="$2"
- local link="6in4-$cfg"
-
- local local4=$(uci_get network "$cfg" ipaddr)
-
- local remote4
- config_get remote4 "$cfg" peeraddr
-
- local local6
- config_get local6 "$cfg" ip6addr
-
- local mtu
- config_get mtu "$cfg" mtu
-
- local ttl
- config_get ttl "$cfg" ttl
-
- local metric
- config_get metric "$cfg" metric
-
- local defaultroute
- config_get_bool defaultroute "$cfg" defaultroute 1
-
- # If local4 is unset, guess local IPv4 address from the
- # interface used by the default route.
- [ -z "$local4" ] && {
- local wanif=$(find_6in4_wanif)
- [ -n "$wanif" ] && {
- local4=$(find_6in4_wanip "$wanif")
- uci_set_state network "$cfg" wan_device "$wanif"
- }
- }
-
- [ -n "$local4" ] && {
- # creating the tunnel below will trigger a net subsystem event
- # prevent it from touching or iface by disabling .auto here
- uci_set_state network "$cfg" ifname $link
- uci_set_state network "$cfg" auto 0
-
- ip tunnel add $link mode sit remote $remote4 local $local4 ttl ${ttl:-64}
- ip link set $link up
- ip link set mtu ${mtu:-1280} dev $link
- ip addr add $local6 dev $link
-
- uci_set_state network "$cfg" ipaddr $local4
- uci_set_state network "$cfg" ip6addr $local6
-
- [ "$defaultroute" = 1 ] && {
- ip -6 route add ::/0 ${metric:+metric $metric} dev $link
- uci_set_state network "$cfg" defaultroute 1
- }
-
- env -i ACTION="ifup" INTERFACE="$cfg" DEVICE="$link" PROTO=6in4 /sbin/hotplug-call "iface" &
- } || {
- echo "Cannot determine local IPv4 address for 6in4 tunnel $cfg - skipping"
- }
-}
-
-stop_interface_6in4() {
- local cfg="$1"
- local link="6in4-$cfg"
-
- local local6=$(uci_get_state network "$cfg" ip6addr)
- local defaultroute=$(uci_get_state network "$cfg" defaultroute)
-
- grep -qs "^ *$link:" /proc/net/dev && {
- env -i ACTION="ifdown" INTERFACE="$cfg" DEVICE="$link" PROTO=6in4 /sbin/hotplug-call "iface" &
-
- [ "$defaultroute" = "1" ] && {
- ip -6 route del ::/0 dev $link
- }
-
- ip addr del $local6 dev $link
- ip link set $link down
- ip tunnel del $link
- }
-}