aboutsummaryrefslogtreecommitdiffstats
path: root/package/6in4
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-06-18 21:40:34 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-06-18 21:40:34 +0000
commit0a73ff2600eba3c72d1e7532d3a25460d7d5e264 (patch)
tree3b2d8f3e829a4b29dff42a86d798a7f40ae7a992 /package/6in4
parentff81d5ec3a2466df68811f8a80baf467859a2191 (diff)
downloadupstream-0a73ff2600eba3c72d1e7532d3a25460d7d5e264.tar.gz
upstream-0a73ff2600eba3c72d1e7532d3a25460d7d5e264.tar.bz2
upstream-0a73ff2600eba3c72d1e7532d3a25460d7d5e264.zip
[package] 6in4, 6to4: further simplify protocol backends
- use new default route dependencies to trigger bringup - remove old hotplug scripts git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32428 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/6in4')
-rw-r--r--package/6in4/Makefile2
-rw-r--r--package/6in4/files/6in4.hotplug29
-rwxr-xr-xpackage/6in4/files/6in4.sh14
3 files changed, 5 insertions, 40 deletions
diff --git a/package/6in4/Makefile b/package/6in4/Makefile
index d91ae84a60..fdab290861 100644
--- a/package/6in4/Makefile
+++ b/package/6in4/Makefile
@@ -37,8 +37,6 @@ endef
define Package/6in4/install
$(INSTALL_DIR) $(1)/lib/netifd/proto
$(INSTALL_BIN) ./files/6in4.sh $(1)/lib/netifd/proto/6in4.sh
- $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
- $(INSTALL_DATA) ./files/6in4.hotplug $(1)/etc/hotplug.d/iface/90-6in4
endef
$(eval $(call BuildPackage,6in4))
diff --git a/package/6in4/files/6in4.hotplug b/package/6in4/files/6in4.hotplug
deleted file mode 100644
index e94179828b..0000000000
--- a/package/6in4/files/6in4.hotplug
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/bin/sh
-
-if [ "$ACTION" = ifup ]; then
- . /lib/functions.sh
-
- INCLUDE_ONLY=1
- . /lib/netifd/proto/6in4.sh
-
- include /lib/network
- scan_interfaces
-
- update_tunnel() {
- local cfg="$1"
-
- local proto
- config_get proto "$cfg" proto
- [ "$proto" = 6in4 ] || return 0
-
- local wandev
- config_get wandev "$cfg" wan_device "$(find_6in4_wanif)"
- [ "$wandev" = "$DEVICE" ] || return 0
-
- local wanip=$(find_6in4_wanip "$wandev")
-
- [ -n "$wanip" ] && ifup "$cfg"
- }
-
- config_foreach update_tunnel interface
-fi
diff --git a/package/6in4/files/6in4.sh b/package/6in4/files/6in4.sh
index 747662c08a..71bc68940c 100755
--- a/package/6in4/files/6in4.sh
+++ b/package/6in4/files/6in4.sh
@@ -9,13 +9,6 @@
init_proto "$@"
}
-tun_error() {
- local cfg="$1"; shift;
-
- [ -n "$1" ] && proto_notify_error "$cfg" "$@"
- proto_block_restart "$cfg"
-}
-
proto_6in4_setup() {
local cfg="$1"
local iface="$2"
@@ -25,14 +18,17 @@ proto_6in4_setup() {
json_get_vars mtu ttl ipaddr peeraddr ip6addr tunnelid username password
[ -z "$ip6addr" -o -z "$peeraddr" ] && {
- tun_error "$cfg" "MISSING_ADDRESS"
+ proto_notify_error "$cfg" "MISSING_ADDRESS"
+ proto_block_restart "$cfg"
return
}
+ ( proto_add_host_dependency "$cfg" 0.0.0.0 )
+
[ -z "$ipaddr" ] && {
local wanif
if ! network_find_wan wanif || ! network_get_ipaddr ipaddr "$wanif"; then
- tun_error "$cfg" "NO_WAN_LINK"
+ proto_notify_error "$cfg" "NO_WAN_LINK"
return
fi
}