aboutsummaryrefslogtreecommitdiffstats
path: root/package/6in4/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-03-19 21:10:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-03-19 21:10:04 +0000
commit8634e64038b8e37b7f788f7f0e1e496a8a90ee05 (patch)
tree9e6d435125d75e64d7845f2ab45c52549b476bc1 /package/6in4/Makefile
parentb2bd2e8cd53d334c3ad41c7e4ac5c3a23493912e (diff)
downloadupstream-8634e64038b8e37b7f788f7f0e1e496a8a90ee05.tar.gz
upstream-8634e64038b8e37b7f788f7f0e1e496a8a90ee05.tar.bz2
upstream-8634e64038b8e37b7f788f7f0e1e496a8a90ee05.zip
6in4: add netifd support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31036 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/6in4/Makefile')
-rw-r--r--package/6in4/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/package/6in4/Makefile b/package/6in4/Makefile
index fb0803a8a6..ee53f5e3ca 100644
--- a/package/6in4/Makefile
+++ b/package/6in4/Makefile
@@ -34,11 +34,20 @@ endef
define Build/Configure
endef
-define Package/6in4/install
- $(INSTALL_DIR) $(1)/lib/network
- $(INSTALL_DATA) ./files/6in4.sh $(1)/lib/network/6in4.sh
+ifneq ($(CONFIG_PACKAGE_netifd),)
+ define Package/6in4/install
+ $(INSTALL_DIR) $(1)/lib/netifd/proto
+ $(INSTALL_BIN) ./files/6in4.sh $(1)/lib/netifd/proto/6in4.sh
$(INSTALL_DIR) $(1)/etc/hotplug.d/iface
$(INSTALL_DATA) ./files/6in4.hotplug $(1)/etc/hotplug.d/iface/90-6in4
-endef
+ endef
+else
+ define Package/6in4/install
+ $(INSTALL_DIR) $(1)/lib/network
+ $(INSTALL_DATA) ./files.old/6in4.sh $(1)/lib/network/6in4.sh
+ $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+ $(INSTALL_DATA) ./files.old/6in4.hotplug $(1)/etc/hotplug.d/iface/90-6in4
+ endef
+endif
$(eval $(call BuildPackage,6in4))