aboutsummaryrefslogtreecommitdiffstats
path: root/package/6in4/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-05-28 00:27:01 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-05-28 00:27:01 +0000
commit278589f5d70dbe790d31cb5015d3723daa739941 (patch)
treef1cc5467c645c08bb5d6401b3819452bfee79065 /package/6in4/Makefile
parentc0820d3261a81a19c99e9c2a0b4595a5f6465e37 (diff)
downloadupstream-278589f5d70dbe790d31cb5015d3723daa739941.tar.gz
upstream-278589f5d70dbe790d31cb5015d3723daa739941.tar.bz2
upstream-278589f5d70dbe790d31cb5015d3723daa739941.zip
add 6in4 - support for static IPv6-in-IPv4 tunnels through /etc/config/network
SVN-Revision: 21589
Diffstat (limited to 'package/6in4/Makefile')
-rw-r--r--package/6in4/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/package/6in4/Makefile b/package/6in4/Makefile
new file mode 100644
index 0000000000..725c283ded
--- /dev/null
+++ b/package/6in4/Makefile
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=6in4
+PKG_VERSION:=1
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/6in4
+ SECTION:=ipv6
+ CATEGORY:=IPv6
+ DEPENDS:=+ip +kmod-ipv6 +kmod-sit
+ TITLE:=IPv6-in-IPv4 configuration support
+ PKGARCH:=all
+endef
+
+define Package/6in4/description
+Provides support for 6in4 tunnels in /etc/config/network.
+Refer to http://wiki.openwrt.org/doc/uci/network for
+configuration details.
+endef
+
+define Build/Compile
+endef
+
+define Build/Configure
+endef
+
+define Package/6in4/install
+ $(INSTALL_DIR) $(1)/lib/network
+ $(INSTALL_DATA) ./files/6in4.sh $(1)/lib/network/6in4.sh
+endef
+
+$(eval $(call BuildPackage,6in4))