aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2023-06-02 13:54:20 +0200
committerPetr Štetiar <ynezz@true.cz>2023-06-13 14:15:21 +0200
commitc05c0699d4798b02f8ee88159236142e08c0c4cd (patch)
tree4ad2889030374d16d08bf8f3e64f31e6da520f86 /include
parent8d557d47445e027134811415899efd685db257da (diff)
downloadupstream-c05c0699d4798b02f8ee88159236142e08c0c4cd.tar.gz
upstream-c05c0699d4798b02f8ee88159236142e08c0c4cd.tar.bz2
upstream-c05c0699d4798b02f8ee88159236142e08c0c4cd.zip
u-boot.mk: add support for config customization
Make it possible to easily customize U-Boot config options via new `UBOOT_CUSTOMIZE_CONFIG` variable, so we don't need to patch config files or override config step with shell hackery. This generic approach uses `config` CLI to tweak the .config as needed, for example: UBOOT_CUSTOMIZE_CONFIG := \ --enable CMD_EFIDEBUG \ --enable CMD_BOOTMENU \ --enable AUTOBOOT \ --enable AUTOBOOT_MENU_SHOW \ --disable AUTOBOOT_KEYED \ --disable AUTOBOOT_USE_MENUKEY \ --disable BOOTMENU_DISABLE_UBOOT_CONSOLE \ --set-val BOOTDELAY 2 Signed-off-by: Petr Štetiar <ynezz@true.cz> (cherry picked from commit 186b97590b9b2f47abc535c9df0687e00e60f78e)
Diffstat (limited to 'include')
-rw-r--r--include/u-boot.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/u-boot.mk b/include/u-boot.mk
index 8945e8e2b8..2b8106410f 100644
--- a/include/u-boot.mk
+++ b/include/u-boot.mk
@@ -83,6 +83,9 @@ endef
define Build/Configure/U-Boot
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIGURE_VARS) $(UBOOT_CONFIG)_config
+ $(if $(strip $(UBOOT_CUSTOMIZE_CONFIG)),
+ $(PKG_BUILD_DIR)/scripts/config --file $(PKG_BUILD_DIR)/.config $(UBOOT_CUSTOMIZE_CONFIG)
+ +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIGURE_VARS) oldconfig)
endef
DTC=$(wildcard $(LINUX_DIR)/scripts/dtc/dtc)