aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2023-05-31 15:19:31 +0200
committerPetr Štetiar <ynezz@true.cz>2023-06-12 22:10:11 +0200
commitee7a223433da78347ebec55900e25aa54eda8833 (patch)
tree9b49beef883cce334e9dc4466c66386baca21395 /include
parent8f1251a95150b0e30d8a07521c8d4b5e1f6a7a7e (diff)
downloadupstream-ee7a223433da78347ebec55900e25aa54eda8833.tar.gz
upstream-ee7a223433da78347ebec55900e25aa54eda8833.tar.bz2
upstream-ee7a223433da78347ebec55900e25aa54eda8833.zip
kernel: fix wrong detection of Linux-Testing-Version in makefile DUMP
When the split was done, the case for testing kernel version wasn't handled and only the to-be-compiled kernel version details files was included. This cause the kernel Linux-Testing-Version output from makefile target DUMP to report only the kernel version without the minor version (example 6.1 instead of 6.1.29). This value is expected with the full kernel version and this cause the dump-target-info.pl script to not correctly identify if a target have a testing kernel for the kernels calls. Fix this regression by correctly including the kernel details files if the target declare support for a testing kernel version. Fixes: 0765466a42f4 ("kernel: split kernel version to dedicated files") Signed-off-by: Christian Marangi <ansuelsmth@gmail.com> (cherry picked from commit 595608eb3f05cba31da59e0d5d82504ab6731c0b)
Diffstat (limited to 'include')
-rw-r--r--include/kernel-version.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 1edb01df27..958ed9be0c 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -13,6 +13,15 @@ endif
include $(KERNEL_DETAILS_FILE)
+ifdef KERNEL_TESTING_PATCHVER
+ KERNEL_TESTING_DETAILS_FILE=$(INCLUDE_DIR)/kernel-$(KERNEL_TESTING_PATCHVER)
+ ifeq ($(wildcard $(KERNEL_TESTING_DETAILS_FILE)),)
+ $(error Missing kernel version/hash file for $(KERNEL_TESTING_PATCHVER). Please create $(KERNEL_TESTING_DETAILS_FILE))
+ endif
+
+ include $(KERNEL_TESTING_DETAILS_FILE)
+endif
+
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))