aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-09-09 12:31:44 -0700
committerChristian Marangi <ansuelsmth@gmail.com>2022-09-11 16:12:29 +0200
commit805be7e90eacf67f0fb3f65304fcd7a65cfc0418 (patch)
tree889298898dd2383cdf679c63f1acffea49d95cab /include
parentbe6f0125514db8967a7181420db8ef20990bd93c (diff)
downloadupstream-805be7e90eacf67f0fb3f65304fcd7a65cfc0418.tar.gz
upstream-805be7e90eacf67f0fb3f65304fcd7a65cfc0418.tar.bz2
upstream-805be7e90eacf67f0fb3f65304fcd7a65cfc0418.zip
prereq-build: add check for stdlib
One way to solve the python3 dependency check is to install python3-minimal instead of python3 on Debian based systems. Unfortunately, this results in a fairly unusable python. Added check for ntpath, which is how the issue originally presented itself. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'include')
-rw-r--r--include/prereq-build.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 67993cf7e3..e1687da370 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -190,6 +190,10 @@ $(eval $(call TestHostCommand,python3-distutils, \
Please install the Python3 distutils module, \
$(STAGING_DIR_HOST)/bin/python3 -c 'from distutils import util'))
+$(eval $(call TestHostCommand,python3-stdlib, \
+ Please install the Python3 stdlib module, \
+ $(STAGING_DIR_HOST)/bin/python3 -c 'import ntpath'))
+
$(eval $(call SetupHostCommand,file,Please install the 'file' package, \
file --version 2>&1 | grep file))