aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2022-10-04 00:30:21 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2022-10-05 17:49:19 +0200
commit7df959449cabee021aa42cab3a7172e0972a79a7 (patch)
treedba282838bd2447a1e688e0e4f4113f907b8cd09 /include
parent3bd04767badd215bf4d005f0b997b2cee5b2d8c3 (diff)
downloadupstream-7df959449cabee021aa42cab3a7172e0972a79a7.tar.gz
upstream-7df959449cabee021aa42cab3a7172e0972a79a7.tar.bz2
upstream-7df959449cabee021aa42cab3a7172e0972a79a7.zip
rules.mk: move DOWNLOAD_CHECK_CERTIFICATE to include/download.mk
Move DOWNLOAD_CHECK_CERTIFICATE to include/download.mk as it's a better place than exporting it in the global rules.mk makefile. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'include')
-rw-r--r--include/download.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/download.mk b/include/download.mk
index 76bd374cf7..9ff71540f7 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -18,6 +18,9 @@ endif
DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
+# Export options for download.pl
+export DOWNLOAD_CHECK_CERTIFICATE:=$(CONFIG_DOWNLOAD_CHECK_CERTIFICATE)
+
define dl_method_git
$(if $(filter https://github.com/% git://github.com/%,$(1)),github_archive,git)
endef