aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2022-08-01 13:30:39 +0900
committerHauke Mehrtens <hauke@hauke-m.de>2022-10-19 22:58:12 +0200
commit00ddd29b650b45cd89f6423dca3eafcc134b7319 (patch)
tree03b65206a1512261b3579f3f1b5a0db2fe51d2d3 /include
parenta80e198cd383593da7f41857a6122f28ed6354a1 (diff)
downloadupstream-00ddd29b650b45cd89f6423dca3eafcc134b7319.tar.gz
upstream-00ddd29b650b45cd89f6423dca3eafcc134b7319.tar.bz2
upstream-00ddd29b650b45cd89f6423dca3eafcc134b7319.zip
build: move Build/edimax-header to image-commands.mk
To use from the following devices in ath79 target, move edimax-header to image-commands.mk. - ELECOM WRC-300GHBK2-I - ELECOM WRC-1750GHBK2-I/C Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 6b4bc4945c..492e6933f1 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -218,6 +218,11 @@ define Build/copy-file
cat "$(1)" > "$@"
endef
+define Build/edimax-header
+ $(STAGING_DIR_HOST)/bin/mkedimaximg -i $@ -o $@.new $(1)
+ @mv $@.new $@
+endef
+
define Build/elecom-product-header
$(eval product=$(word 1,$(1)))
$(eval fw=$(if $(word 2,$(1)),$(word 2,$(1)),$@))