aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2023-02-05 19:38:09 +0100
committerPaul Spooren <mail@aparcar.org>2023-05-08 20:03:44 +0200
commit91e3419a33f3f0baa2fb25680f5c9a7b2240102b (patch)
tree7864b2d0eaa80456b6c9afc47e5c00e3341cf93f /include
parent36dd3ab7db0dfa6ea769f49983142a522ec15994 (diff)
downloadupstream-91e3419a33f3f0baa2fb25680f5c9a7b2240102b.tar.gz
upstream-91e3419a33f3f0baa2fb25680f5c9a7b2240102b.tar.bz2
upstream-91e3419a33f3f0baa2fb25680f5c9a7b2240102b.zip
ath79: add empty squashfs-lzma filesystem
The filesystem is currently created on every build to trick the boot loader of some FRITZ! devices into accepting the image. Sadly the resulting squashfs-lzma filesystem is not reproducible. To fix this, create a squashfs filesystem once and include it into the repository. Creation happend as shown below rm -rf empty_dir mkdir empty_dir ./staging_dir/host/bin/mksquashfs-lzma \ empty_dir/ empty-squashfs-lzma \ -noappend -root-owned -be -nopad -b 65536 -fixed-time 0 Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk10
1 files changed, 0 insertions, 10 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 0c13f30fef..e1951672e6 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -103,16 +103,6 @@ define Build/append-rootfs
dd if=$(IMAGE_ROOTFS) >> $@
endef
-define Build/append-squashfs-fakeroot-be
- rm -rf $@.fakefs $@.fakesquashfs
- mkdir $@.fakefs
- $(STAGING_DIR_HOST)/bin/mksquashfs3-lzma \
- $@.fakefs $@.fakesquashfs \
- -noappend -root-owned -be -nopad -b 65536 \
- $(if $(SOURCE_DATE_EPOCH),-fixed-time $(SOURCE_DATE_EPOCH))
- cat $@.fakesquashfs >> $@
-endef
-
define Build/append-squashfs4-fakeroot
rm -rf $@.fakefs $@.fakesquashfs
mkdir $@.fakefs