aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2023-05-16 03:22:09 -0400
committerPetr Štetiar <ynezz@true.cz>2023-05-21 19:57:06 +0200
commit7f0db09513c88e9c68f121d33cf56754e967b349 (patch)
tree35bfcdf8454230d7685fa613f51aeaaf6ac6cb0b /include
parentfdfb848402cb7c43f63be1868d79c30780d1901c (diff)
downloadupstream-7f0db09513c88e9c68f121d33cf56754e967b349.tar.gz
upstream-7f0db09513c88e9c68f121d33cf56754e967b349.tar.bz2
upstream-7f0db09513c88e9c68f121d33cf56754e967b349.zip
prereq-build: remove python 2 cleanup recipe
This reverts commit 3b68fb57c938af3948ae4c2da61501183fbef649. After refactoring build checks to update old symlinks, and after a long time of no python 2 support, this is no longer needed. Signed-off-by: Michael Pratt <mcpratt@pm.me> (cherry picked from commit e2f9fa42044a2660f702a9b51b14cbde24a13702)
Diffstat (limited to 'include')
-rw-r--r--include/prereq-build.mk2
-rw-r--r--include/prereq.mk12
2 files changed, 0 insertions, 14 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 14a2210880..52988fbda9 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -175,8 +175,6 @@ $(eval $(call SetupHostCommand,install,Please install GNU 'install', \
$(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
perl --version | grep "perl.*v5"))
-$(eval $(call CleanupPython2))
-
$(eval $(call SetupHostCommand,python,Please install Python >= 3.6, \
python3.11 -V 2>&1 | grep 'Python 3', \
python3.10 -V 2>&1 | grep 'Python 3', \
diff --git a/include/prereq.mk b/include/prereq.mk
index 89660d323d..5646b24efa 100644
--- a/include/prereq.mk
+++ b/include/prereq.mk
@@ -77,18 +77,6 @@ define RequireCHeader
$$(eval $$(call Require,$(1),$(2)))
endef
-define CleanupPython2
- define Require/python2-cleanup
- if [ -f "$(STAGING_DIR_HOST)/bin/python" ] && \
- $(STAGING_DIR_HOST)/bin/python -V 2>&1 | \
- grep -q 'Python 2'; then \
- rm $(STAGING_DIR_HOST)/bin/python; \
- fi
- endef
-
- $$(eval $$(call Require,python2-cleanup))
-endef
-
define QuoteHostCommand
'$(subst ','"'"',$(strip $(1)))'
endef