aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2023-01-09 22:16:26 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-01-10 13:07:14 +0100
commit7af1713a29441c47330f9dd1b1f1c9772af5e033 (patch)
tree3dd844a7a6cf08cc8e7ab1e969ad4d4bd2d68a5d /include
parentee397759b65a1e2ab9a58be37c22c9b3bdfd7a7e (diff)
downloadupstream-7af1713a29441c47330f9dd1b1f1c9772af5e033.tar.gz
upstream-7af1713a29441c47330f9dd1b1f1c9772af5e033.tar.bz2
upstream-7af1713a29441c47330f9dd1b1f1c9772af5e033.zip
prereq-build: limit argp/fts/obstack/libintl.h to Linux OS
BSD based OS have different fixup and doesn't require these header. Limit these Header to Linux based OS. Fixes: 36bc306ae611 ("prereq-build: add extra check for elfutils required header") Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'include')
-rw-r--r--include/prereq-build.mk10
1 files changed, 6 insertions, 4 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 7b345ebbaa..8fae92ab97 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -204,17 +204,19 @@ $(eval $(call SetupHostCommand,which,Please install 'which', \
/bin/which which, \
which which))
-$(eval $(call RequireCHeader,argp.h, \
+ifeq ($(HOST_OS),Linux)
+ $(eval $(call RequireCHeader,argp.h, \
Missing argp.h Please install the argp-standalone package if musl libc))
-$(eval $(call RequireCHeader,fts.h, \
+ $(eval $(call RequireCHeader,fts.h, \
Missing fts.h Please install the musl-fts-dev package if musl libc))
-$(eval $(call RequireCHeader,obstack.h, \
+ $(eval $(call RequireCHeader,obstack.h, \
Missing obstack.h Please install the musl-obstack-dev package if musl libc))
-$(eval $(call RequireCHeader,libintl.h, \
+ $(eval $(call RequireCHeader,libintl.h, \
Missing libintl.h Please install the musl-libintl package if musl libc))
+endif
$(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
mkdir -p $(dir $@)