aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorTony Butler <spudz76@gmail.com>2023-04-17 19:32:18 -0700
committerChristian Marangi <ansuelsmth@gmail.com>2023-04-18 13:57:48 +0200
commit4ab4b9ea818d24b66df146ef1c34ea7e9096b775 (patch)
tree4f7d8baef8d442a0675a4557618ef0122805698f /include
parent69bc620180d2ec670e7a936171262fc3e9e99179 (diff)
downloadupstream-4ab4b9ea818d24b66df146ef1c34ea7e9096b775.tar.gz
upstream-4ab4b9ea818d24b66df146ef1c34ea7e9096b775.tar.bz2
upstream-4ab4b9ea818d24b66df146ef1c34ea7e9096b775.zip
build: fix incorrect initramfs gzip compression
Requires: tools/libdeflate fix consistency of executable to use `$(STAGING_DIR_HOST)/bin/libdeflate-gzip`, and not system-installed ones from the usual environment `PATH`; this affects option `CONFIG_KERNEL_INITRAMFS_COMPRESSION_GZIP` this may have worked in the past but only via side effect of having the binaries on the host system (and whatever unpredictable version or patchset those might be), and did not use the improved but totally compatible libdeflate-gzip Fixes: 330bd380e8b6 ("image: allow building FIT and uImage with ramdisk") Signed-off-by: Tony Butler <spudz76@gmail.com>
Diffstat (limited to 'include')
-rw-r--r--include/kernel-defaults.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index c1976ee6c7..4029dad738 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -178,7 +178,7 @@ else
endif
$(if $(SOURCE_DATE_EPOCH),touch -hcd "@$(SOURCE_DATE_EPOCH)" $(KERNEL_BUILD_DIR)/initrd.cpio)
$(if $(CONFIG_TARGET_INITRAMFS_COMPRESSION_BZIP2),$(STAGING_DIR_HOST)/bin/bzip2 -9 -c < $(KERNEL_BUILD_DIR)/initrd.cpio > $(KERNEL_BUILD_DIR)/initrd.cpio.bzip2)
- $(if $(CONFIG_TARGET_INITRAMFS_COMPRESSION_GZIP),gzip -n -f -S .gzip -9n $(KERNEL_BUILD_DIR)/initrd.cpio)
+ $(if $(CONFIG_TARGET_INITRAMFS_COMPRESSION_GZIP),$(STAGING_DIR_HOST)/bin/libdeflate-gzip -n -f -S .gzip -12 $(KERNEL_BUILD_DIR)/initrd.cpio)
$(if $(CONFIG_TARGET_INITRAMFS_COMPRESSION_LZ4),$(STAGING_DIR_HOST)/bin/lz4c -l -c1 -fz --favor-decSpeed $(KERNEL_BUILD_DIR)/initrd.cpio)
$(if $(CONFIG_TARGET_INITRAMFS_COMPRESSION_LZMA),$(STAGING_DIR_HOST)/bin/lzma e -lc1 -lp2 -pb2 $(KERNEL_BUILD_DIR)/initrd.cpio $(KERNEL_BUILD_DIR)/initrd.cpio.lzma)
$(if $(CONFIG_TARGET_INITRAMFS_COMPRESSION_LZO),$(STAGING_DIR_HOST)/bin/lzop -9 -f $(KERNEL_BUILD_DIR)/initrd.cpio)