aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorSven Roederer <S.Roederer@colvistec.de>2023-05-11 12:42:12 +0200
committerChristian Lamparter <chunkeey@gmail.com>2023-05-20 15:19:14 +0200
commit4071398b13aeee873cb5a48b00b6c90074763d5f (patch)
tree0b07b3b7c797b9fa8ed0835e7c6a0c8194f85905 /include
parenteab9de0c9c05e1a057e4c9112c4802c7f8fe9a3d (diff)
downloadupstream-4071398b13aeee873cb5a48b00b6c90074763d5f.tar.gz
upstream-4071398b13aeee873cb5a48b00b6c90074763d5f.tar.bz2
upstream-4071398b13aeee873cb5a48b00b6c90074763d5f.zip
build: escape whitespaces in VERSION_DIST for Netgear images
Prevents subshell commands from failing to parse options when having defined a whitespace in the VERSION_DIST. As the called resulting images unlikely will handle whitespace correctly, we replace them by "-". Signed-off-by: Sven Roederer <S.Roederer@colvistec.de>
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 0c13f30fef..6c385b85e8 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -410,7 +410,7 @@ endef
define Build/netgear-dni
$(STAGING_DIR_HOST)/bin/mkdniimg \
- -B $(NETGEAR_BOARD_ID) -v $(VERSION_DIST).$(firstword $(subst -, ,$(REVISION))) \
+ -B $(NETGEAR_BOARD_ID) -v $(shell cat $(VERSION_DIST)| sed -e 's/[[:space:]]/-/g').$(firstword $(subst -, ,$(REVISION))) \
$(if $(NETGEAR_HW_ID),-H $(NETGEAR_HW_ID)) \
-r "$(1)" \
-i $@ -o $@.new
@@ -423,7 +423,7 @@ define Build/netgear-encrypted-factory
--output-file $@ \
--model $(NETGEAR_ENC_MODEL) \
--region $(NETGEAR_ENC_REGION) \
- --version V1.0.0.0.$(VERSION_DIST).$(firstword $(subst -, ,$(REVISION))) \
+ --version V1.0.0.0.$(shell cat $(VERSION_DIST)| sed -e 's/[[:space:]]/-/g').$(firstword $(subst -, ,$(REVISION))) \
--encryption-block-size 0x20000 \
--openssl-bin "$(STAGING_DIR_HOST)/bin/openssl" \
--key 6865392d342b4d212964363d6d7e7765312c7132613364316e26322a5a5e2538 \