aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2023-01-18 12:22:12 +0100
committerDoug Freed <dwfreed@mtu.edu>2023-02-09 08:37:35 +0000
commitf7541aecdc0658051f492016733a64a1de4904bd (patch)
treecccd07d235d959b639f882f95881d52e1a5729f8 /include
parent98b8507e83c69d5e66e442eca95fc076114a736a (diff)
downloadupstream-f7541aecdc0658051f492016733a64a1de4904bd.tar.gz
upstream-f7541aecdc0658051f492016733a64a1de4904bd.tar.bz2
upstream-f7541aecdc0658051f492016733a64a1de4904bd.zip
bpf: ignore missing LLVM bins on package for non compile steps
To download a package the LLVM bins are not strictly needed. Currently with an example run of make package/bridger/download V=s, the build fail with make[2]: Entering directory '/home/ansuel/openwrt-ansuel/openwrt/package/network/services/bridger' bash: line 1: /home/ansuel/openwrt-ansuel/openwrt/staging_dir/host/llvm-bpf/bin/clang: No such file or directory bash: line 1: [: : integer expression expected /home/ansuel/openwrt-ansuel/openwrt/include/bpf.mk:71: *** ERROR: LLVM/clang version too old. Minimum required: 12, found: . Stop. make[2]: Leaving directory '/home/ansuel/openwrt-ansuel/openwrt/package/network/services/bridger' time: package/network/services/bridger/download#0.04#0.00#0.06 ERROR: package/network/services/bridger failed to build. This is wrong since it may be needed to download the required packages first and then compile them later. Fix this by ignoring the LLVM bin check on non compile steps. Tested-by: Robert Marko <robimarko@gmail.com> Signed-off-by: Christian Marangi <ansuelsmth@gmail.com> (cherry picked from commit 116c73fd71c75e38c4d707dc5a74e6993874098f)
Diffstat (limited to 'include')
-rw-r--r--include/bpf.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/bpf.mk b/include/bpf.mk
index e43fcad50c..ec3f04e1e9 100644
--- a/include/bpf.mk
+++ b/include/bpf.mk
@@ -64,7 +64,7 @@ BPF_CFLAGS := \
-O2 -emit-llvm -Xclang -disable-llvm-passes
ifneq ($(CONFIG_HAS_BPF_TOOLCHAIN),)
-ifeq ($(DUMP),)
+ifeq ($(DUMP)$(filter download refresh,$(MAKECMDGOALS)),)
CLANG_VER:=$(shell $(CLANG) -dM -E - < /dev/null | grep __clang_major__ | cut -d' ' -f3)
CLANG_VER_VALID:=$(shell [ "$(CLANG_VER)" -ge "$(CLANG_MIN_VER)" ] && echo 1 )
ifeq ($(CLANG_VER_VALID),)