aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorChristian 'Ansuel' Marangi <ansuelsmth@gmail.com>2022-06-09 14:13:09 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-06-27 19:54:12 +0200
commit7e223a89a17e122f2dfad246e5e5ada8f1793dd7 (patch)
tree8a3686ad96ab08c22b97da2ec7bfde418862f4f6 /include
parent08e1812900b4f2ab0d7a33b0e72be2d377a5b3d9 (diff)
downloadupstream-7e223a89a17e122f2dfad246e5e5ada8f1793dd7.tar.gz
upstream-7e223a89a17e122f2dfad246e5e5ada8f1793dd7.tar.bz2
upstream-7e223a89a17e122f2dfad246e5e5ada8f1793dd7.zip
prereq-build: add additional git detection
With some OS (Guix) the git submodule command is wrapped in a script. Current logic parse the git submodule script directly. If it's wrapped the prereq check wrongly fails while 'git submodule --recursive' is actually available. Add an additional check that try to directly use the 'git submodule' command to check if the prereq is satisfied. Fixes: #9986 Reported-by: Attila Lendvai <attila@lendvai.name> Suggested-by: Attila Lendvai <attila@lendvai.name> Signed-off-by: Christian 'Ansuel' Marangi <ansuelsmth@gmail.com> (cherry picked from commit ab1f3a87063b94f485bd582f32a066b80007bac9)
Diffstat (limited to 'include')
-rw-r--r--include/prereq-build.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index e1918f0027..4a8c2b063a 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -177,7 +177,8 @@ $(eval $(call TestHostCommand,python3-distutils, \
$(STAGING_DIR_HOST)/bin/python3 -c 'import distutils'))
$(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
- git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule))
+ git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule, \
+ git submodule --help | grep -- --recursive))
$(eval $(call SetupHostCommand,file,Please install the 'file' package, \
file --version 2>&1 | grep file))