aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-05-03 15:01:03 +0200
committerFelix Fietkau <nbd@nbd.name>2017-05-25 19:01:07 +0200
commitf62f4b3c5c9d059a2e6a1e80ce7b4267ef0c236b (patch)
tree96563a32e7c0f1b7d96bae85defb7f17bae626ec /include
parenta76cbc0d7ec2a816682063bdc18d114ec0711113 (diff)
downloadupstream-f62f4b3c5c9d059a2e6a1e80ce7b4267ef0c236b.tar.gz
upstream-f62f4b3c5c9d059a2e6a1e80ce7b4267ef0c236b.tar.bz2
upstream-f62f4b3c5c9d059a2e6a1e80ce7b4267ef0c236b.zip
build: stop overriding STAGING_DIR_HOST for toolchain build
This causes various issues in other places that assume that host binaries are staged in STAGING_DIR_HOST. Since all the right places use HOST_BUILD_PREFIX, override that instead. This fixes some issues with quilt on toolchain dirs Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include')
-rw-r--r--include/host-build.mk2
-rw-r--r--include/toolchain-build.mk3
2 files changed, 2 insertions, 3 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 70da733d43..dc70373855 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -27,7 +27,7 @@ BUILD_TYPES += host
HOST_STAMP_PREPARED:=$(HOST_BUILD_DIR)/.prepared$(if $(HOST_QUILT)$(DUMP),,$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPENDS),))_$(call confvar,CONFIG_AUTOREMOVE $(HOST_PREPARED_DEPENDS)))
HOST_STAMP_CONFIGURED:=$(HOST_BUILD_DIR)/.configured
HOST_STAMP_BUILT:=$(HOST_BUILD_DIR)/.built
-HOST_BUILD_PREFIX:=$(if $(IS_PACKAGE_BUILD),$(STAGING_DIR_HOSTPKG),$(STAGING_DIR_HOST))
+HOST_BUILD_PREFIX?=$(if $(IS_PACKAGE_BUILD),$(STAGING_DIR_HOSTPKG),$(STAGING_DIR_HOST))
HOST_STAMP_INSTALLED:=$(HOST_BUILD_PREFIX)/stamp/.$(PKG_NAME)_installed
override MAKEFLAGS=
diff --git a/include/toolchain-build.mk b/include/toolchain-build.mk
index efc35e2789..883d74d25c 100644
--- a/include/toolchain-build.mk
+++ b/include/toolchain-build.mk
@@ -8,8 +8,7 @@
override CONFIG_AUTOREBUILD=
override CONFIG_AUTOREMOVE=
-REAL_STAGING_DIR_HOST:=$(STAGING_DIR_HOST)
-STAGING_DIR_HOST:=$(TOOLCHAIN_DIR)
+HOST_BUILD_PREFIX:=$(TOOLCHAIN_DIR)
BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
include $(INCLUDE_DIR)/host-build.mk