aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorAnsuel Smith <ansuelsmth@gmail.com>2022-01-10 17:02:30 +0100
committerRui Salvaterra <rsalvaterra@gmail.com>2022-01-13 23:46:39 +0000
commit0765466a42f46f7357e260866a4284ed567bb7ad (patch)
treebc083cdef1a87afef730d25ab16a90a17badb37f /include
parent0637093e8cb0e4cfb94dfcfe7b57afc23bf88852 (diff)
downloadupstream-0765466a42f46f7357e260866a4284ed567bb7ad.tar.gz
upstream-0765466a42f46f7357e260866a4284ed567bb7ad.tar.bz2
upstream-0765466a42f46f7357e260866a4284ed567bb7ad.zip
kernel: split kernel version to dedicated files
Move the kernel versions and hash to dedicated files. This makes kernel bump quicker and fix some annoying problem with rebasing when multiple kernel bump are proposed. Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com> [Rebased on top of current master] Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
Diffstat (limited to 'include')
-rw-r--r--include/kernel-5.102
-rw-r--r--include/kernel-5.42
-rw-r--r--include/kernel-version.mk9
3 files changed, 9 insertions, 4 deletions
diff --git a/include/kernel-5.10 b/include/kernel-5.10
new file mode 100644
index 0000000000..e816698dec
--- /dev/null
+++ b/include/kernel-5.10
@@ -0,0 +1,2 @@
+LINUX_VERSION-5.10 = .90
+LINUX_KERNEL_HASH-5.10.90 = 945e4264c014a3d9dfc0a4639309dd1ec2fb545416556421f931b95da78c2725
diff --git a/include/kernel-5.4 b/include/kernel-5.4
new file mode 100644
index 0000000000..e85b7ad68e
--- /dev/null
+++ b/include/kernel-5.4
@@ -0,0 +1,2 @@
+LINUX_VERSION-5.4 = .170
+LINUX_KERNEL_HASH-5.4.170 = b09f74e0cf5fc7cf5de6aa932fe654c962cb10118bdbbdddb397022c6e6d382c
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 677693ad08..1edb01df27 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -6,11 +6,12 @@ ifdef CONFIG_TESTING_KERNEL
KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
endif
-LINUX_VERSION-5.4 = .170
-LINUX_VERSION-5.10 = .90
+KERNEL_DETAILS_FILE=$(INCLUDE_DIR)/kernel-$(KERNEL_PATCHVER)
+ifeq ($(wildcard $(KERNEL_DETAILS_FILE)),)
+ $(error Missing kernel version/hash file for $(KERNEL_PATCHVER). Please create $(KERNEL_DETAILS_FILE))
+endif
-LINUX_KERNEL_HASH-5.4.170 = b09f74e0cf5fc7cf5de6aa932fe654c962cb10118bdbbdddb397022c6e6d382c
-LINUX_KERNEL_HASH-5.10.90 = 945e4264c014a3d9dfc0a4639309dd1ec2fb545416556421f931b95da78c2725
+include $(KERNEL_DETAILS_FILE)
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))