aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2022-09-27 13:39:12 +0200
committerFelix Fietkau <nbd@nbd.name>2022-09-27 13:45:03 +0200
commit25d8b9cad6f141104a1065880efe21b8c292d8c6 (patch)
tree5946d0f8fec279f03e5113d2e9ff1108c46a9c07 /include
parent74eeee1698e8ee2031ab882174b1a07d2c553409 (diff)
downloadupstream-25d8b9cad6f141104a1065880efe21b8c292d8c6.tar.gz
upstream-25d8b9cad6f141104a1065880efe21b8c292d8c6.tar.bz2
upstream-25d8b9cad6f141104a1065880efe21b8c292d8c6.zip
build: fix issues with targets installed via feeds
- fix including modules.mk when a target is being replaced - fix calling make targets from target/linux Signed-off-by: Felix Fietkau <nbd@nbd.name> (cherry-picked from commit 3a8825ad6acbf18b2b472ace56be58868af78be7)
Diffstat (limited to 'include')
-rw-r--r--include/target.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/target.mk b/include/target.mk
index a2c8b7bdbf..708ba395c6 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -68,7 +68,7 @@ endif
target_conf=$(subst .,_,$(subst -,_,$(subst /,_,$(1))))
ifeq ($(DUMP),)
- PLATFORM_DIR:=$(TOPDIR)/target/linux/$(BOARD)
+ PLATFORM_DIR:=$(firstword $(wildcard $(TOPDIR)/target/linux/feeds/$(BOARD) $(TOPDIR)/target/linux/$(BOARD)))
SUBTARGET:=$(strip $(foreach subdir,$(patsubst $(PLATFORM_DIR)/%/target.mk,%,$(wildcard $(PLATFORM_DIR)/*/target.mk)),$(if $(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(subdir))),$(subdir))))
else
PLATFORM_DIR:=${CURDIR}