aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-10-04 18:48:30 -0700
committerPaul Spooren <mail@aparcar.org>2021-10-07 14:09:40 -1000
commitc2222f74c8eff592032473ab2d29d5e8febace63 (patch)
treef15fb0d9c14946785d6731d1c80bf8680d56d913 /include
parente4e410733f3b0cad09d3a235eec0b04f4068c331 (diff)
downloadupstream-c2222f74c8eff592032473ab2d29d5e8febace63.tar.gz
upstream-c2222f74c8eff592032473ab2d29d5e8febace63.tar.bz2
upstream-c2222f74c8eff592032473ab2d29d5e8febace63.zip
tools/meson: update to 0.59.2
Update install procedure based on upstream feedback. Normally, meson is to be installed with pip. But as pip is not mandated by the build system, it cannot be used. Upstream provides a nice script to pack meson automatically. Moved src/ to files/. No need to copy to BUILD_DIR. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'include')
-rw-r--r--include/meson.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/include/meson.mk b/include/meson.mk
index 01d0ce0280..9862f0e662 100644
--- a/include/meson.mk
+++ b/include/meson.mk
@@ -19,7 +19,6 @@
#
# Host packages are built in the same fashion, just use these vars instead:
#
-# HOST_BUILD_DEPENDS:=meson/host
# MESON_HOST_ARGS+=-Dfoo -Dbar=baz
# MESON_HOST_VARS+=FOO=bar
@@ -57,7 +56,7 @@ MESON_CPU:="$(CPU_TYPE)$(if $(CPU_SUBTYPE),+$(CPU_SUBTYPE))"
endif
define Meson
- $(2) $(STAGING_DIR_HOST)/bin/$(PYTHON) $(MESON_DIR)/meson.py $(1)
+ $(2) $(STAGING_DIR_HOST)/bin/meson $(1)
endef
define Meson/CreateNativeFile