aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2022-02-28 10:14:25 +0100
committerPaul Spooren <mail@aparcar.org>2022-02-28 23:52:13 +0100
commitaee3594ffcb72ae3e18c3719012d52519ee2d160 (patch)
tree467ec49bf0937d58b14b8d8c9757e166b420fbdc /include
parentd4c20ff948fc9c64b03af648f911f222fcb593a2 (diff)
downloadupstream-aee3594ffcb72ae3e18c3719012d52519ee2d160.tar.gz
upstream-aee3594ffcb72ae3e18c3719012d52519ee2d160.tar.bz2
upstream-aee3594ffcb72ae3e18c3719012d52519ee2d160.zip
verbose.mk: print ERROR messages in non-verbose
Using `make -j9` only prints a subset of messages to follow the build process progressing. However this silently skips over errors which might be of interested. Using `make V=s` easily floods the terminal making it hard to find error messages between the lines. A compromise is the usage of `$(call ERROR_MESSAGE,...)` which prints a message in red. This function is silenced in the non-verbose mode, even if only used at a single place in `package/Makefile` where it notifies about a OPKG corner case. This commit moves the `ERROR_MESSAGE` definition outside of the `OPENWRT_VERBOSE` condition and print error messages in every mode. With this in place further error messages are possible. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'include')
-rw-r--r--include/verbose.mk9
1 files changed, 4 insertions, 5 deletions
diff --git a/include/verbose.mk b/include/verbose.mk
index 3ecf842d11..4487a207e8 100644
--- a/include/verbose.mk
+++ b/include/verbose.mk
@@ -29,15 +29,15 @@ ifeq ($(IS_TTY),1)
endif
endif
+define ERROR_MESSAGE
+ printf "$(_R)%s$(_N)\n" "$(1)" >&8
+endef
+
ifeq ($(findstring s,$(OPENWRT_VERBOSE)),)
define MESSAGE
printf "$(_Y)%s$(_N)\n" "$(1)" >&8
endef
- define ERROR_MESSAGE
- printf "$(_R)%s$(_N)\n" "$(1)" >&8
- endef
-
ifeq ($(QUIET),1)
ifneq ($(CURDIR),$(TOPDIR))
_DIR:=$(patsubst $(TOPDIR)/%,%,${CURDIR})
@@ -60,5 +60,4 @@ else
define MESSAGE
printf "%s\n" "$(1)"
endef
- ERROR_MESSAGE=$(MESSAGE)
endif