aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorDamien Mascord <tusker@tusker.org>2021-11-01 20:06:20 +1100
committerBaptiste Jonglez <git@bitsofnetworks.org>2022-07-04 10:08:08 +0200
commitbd84d517eb95df96d6e9dccac387a135a6cc4065 (patch)
tree85822b4f01619681c53030bd2a0ef8475e6c97b4 /include
parent3439c2ff7092d193bd27dae0ecf7f2071683ce68 (diff)
downloadupstream-bd84d517eb95df96d6e9dccac387a135a6cc4065.tar.gz
upstream-bd84d517eb95df96d6e9dccac387a135a6cc4065.tar.bz2
upstream-bd84d517eb95df96d6e9dccac387a135a6cc4065.zip
build: fix ldconfig executable error in python
The empty executable is causing problems with meson builds, due to the error: OSError: [Errno 8] Exec format error: 'ldconfig' This patch changes the empty ldconfig stub to symlink to /bin/true to work around this issue. Fixes: FS#4117 Fixes: 3bd31cc4d2ff ("tools/meson: update to 0.60.0") Signed-off-by: Damien Mascord <tusker@tusker.org> Tested-by: Aleksander Jan Bajkowski <olek2@wp.pl> # Tested on Debian 11 Tested-By: Lucian Cristian <lucian.cristian@gmail.com> Tested-By: Baptiste Jonglez <git@bitsofnetworks.org> Cc: Rosen Penev <rosenp@gmail.com> (cherry picked from commit 6a5b4228e30244b44a49f523dea66caf3fbe3307) Signed-off-by: Baptiste Jonglez <git@bitsofnetworks.org> [backport to fix prereq check when moving from 22.03 branch to 21.02]
Diffstat (limited to 'include')
-rw-r--r--include/prereq-build.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index d28432f726..d3593b0205 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -196,5 +196,4 @@ prereq: $(STAGING_DIR_HOST)/bin/mkhash
# Install ldconfig stub
$(eval $(call TestHostCommand,ldconfig-stub,Failed to install stub, \
- touch $(STAGING_DIR_HOST)/bin/ldconfig && \
- chmod +x $(STAGING_DIR_HOST)/bin/ldconfig))
+ $(LN) /bin/true $(STAGING_DIR_HOST)/bin/ldconfig))