aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2022-06-15 10:41:37 +0200
committerRafał Miłecki <rafal@milecki.pl>2022-07-08 15:38:42 +0200
commit44fa330a8254893ec81e5b3df16299f32a0f053f (patch)
tree5d77b7253bdd68636981150cdec509ea4ccdea13 /include
parentbd84d517eb95df96d6e9dccac387a135a6cc4065 (diff)
downloadupstream-44fa330a8254893ec81e5b3df16299f32a0f053f.tar.gz
upstream-44fa330a8254893ec81e5b3df16299f32a0f053f.tar.bz2
upstream-44fa330a8254893ec81e5b3df16299f32a0f053f.zip
kernel: use KCFLAGS for passing EXTRA_OPTIMIZATION flags
This uses kernel's generic variable and doesn't require patching it with a custom Makefile change. It's expected *not* to change any behaviour. Signed-off-by: Rafał Miłecki <rafal@milecki.pl> (cherry picked from commit 1d42af720c6b6dcfcdd0b89bce386fca1607dcb3) Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk> (cherry picked from commit 24e27bec9a6df1511a504cf04cd9578a23e74657)
Diffstat (limited to 'include')
-rw-r--r--include/kernel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index e4074a48f4..5057d8bf6f 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -101,7 +101,7 @@ endif
KERNEL_MAKE = $(MAKE) $(KERNEL_MAKEOPTS)
KERNEL_MAKE_FLAGS = \
- KCFLAGS="$(call iremap,$(BUILD_DIR),$(notdir $(BUILD_DIR)))" \
+ KCFLAGS="$(call iremap,$(BUILD_DIR),$(notdir $(BUILD_DIR))) $(filter-out -fno-plt,$(call qstrip,$(CONFIG_EXTRA_OPTIMIZATION)))" \
HOSTCFLAGS="$(HOST_CFLAGS) -Wall -Wmissing-prototypes -Wstrict-prototypes" \
CROSS_COMPILE="$(KERNEL_CROSS)" \
ARCH="$(LINUX_KARCH)" \