aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2020-03-24 11:05:27 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2020-05-24 14:43:08 +0200
commit7b3ada8c6df8e0032acabd48ec8bff0d75643759 (patch)
tree3db35076e0996a80f5d8f7c8c68d73e2904de4cf /include
parente1d4612e0a080e8dfb4855e791359f44ac8d792f (diff)
downloadupstream-7b3ada8c6df8e0032acabd48ec8bff0d75643759.tar.gz
upstream-7b3ada8c6df8e0032acabd48ec8bff0d75643759.tar.bz2
upstream-7b3ada8c6df8e0032acabd48ec8bff0d75643759.zip
build: prereq: tidy gcc version checks
There is a restriction in the number of parameters(10) that may be passed to the SetupHostCommand macro so continually adding explicit gcc'n' version checks ends up breaking the compiler check for the later versions and oddballs like Darwin as was done in 835d1c68a0 which added gcc10. Drop all the explicitly specified gcc version checks. If a suitable gcc compiler is not found, it may be specified at the dependency checking stage after which that version will be symlinked into the build staging host directory. eg. 'CC=gccfoo CXX=g++foo make prereq' Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk> Acked-by: Jo-Philipp Wich <jo@mein.io> (cherry picked from commit 1fb3c003d68d3feaf797e8b64edccc9fa622d250)
Diffstat (limited to 'include')
-rw-r--r--include/prereq-build.mk16
1 files changed, 0 insertions, 16 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 89cc849cc1..501739968c 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -30,14 +30,6 @@ $(eval $(call SetupHostCommand,gcc, \
Please install the GNU C Compiler (gcc) 4.8 or later, \
$(CC) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
gcc -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
- gcc48 --version | grep gcc, \
- gcc49 --version | grep gcc, \
- gcc5 --version | grep gcc, \
- gcc6 --version | grep gcc, \
- gcc7 --version | grep gcc, \
- gcc8 --version | grep gcc, \
- gcc9 --version | grep gcc, \
- gcc10 --version | grep gcc, \
gcc --version | grep -E 'Apple.(LLVM|clang)' ))
$(eval $(call TestHostCommand,working-gcc, \
@@ -50,14 +42,6 @@ $(eval $(call SetupHostCommand,g++, \
Please install the GNU C++ Compiler (g++) 4.8 or later, \
$(CXX) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
g++ -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
- g++48 --version | grep g++, \
- g++49 --version | grep g++, \
- g++5 --version | grep g++, \
- g++6 --version | grep g++, \
- g++7 --version | grep g++, \
- g++8 --version | grep g++, \
- g++9 --version | grep g++, \
- g++10 --version | grep g++, \
g++ --version | grep -E 'Apple.(LLVM|clang)' ))
$(eval $(call TestHostCommand,working-g++, \