aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2017-11-07 09:45:52 +0100
committerFelix Fietkau <nbd@nbd.name>2017-12-08 19:41:18 +0100
commit7b5c989ab9bcd0c1346b7b90b8433216f7b20b71 (patch)
treebbafa6432bc6385d66f880602819878b2f076c18 /include
parentbf5cef47b38c0b119dc84a78919944e21d5c4092 (diff)
downloadupstream-7b5c989ab9bcd0c1346b7b90b8433216f7b20b71.tar.gz
upstream-7b5c989ab9bcd0c1346b7b90b8433216f7b20b71.tar.bz2
upstream-7b5c989ab9bcd0c1346b7b90b8433216f7b20b71.zip
merge: targets: update image generation and targets
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk6
-rw-r--r--include/image.mk2
2 files changed, 4 insertions, 4 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 8db046bdea..5f0ac6164d 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -7,7 +7,7 @@ define Build/uImage
mkimage -A $(LINUX_KARCH) \
-O linux -T kernel \
-C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
- -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) LEDE Linux-$(LINUX_VERSION))' -d $@ $@.new
+ -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) OpenWrt Linux-$(LINUX_VERSION))' -d $@ $@.new
mv $@.new $@
endef
@@ -60,7 +60,7 @@ endef
define Build/netgear-dni
$(STAGING_DIR_HOST)/bin/mkdniimg \
- -B $(NETGEAR_BOARD_ID) -v LEDE.$(REVISION) \
+ -B $(NETGEAR_BOARD_ID) -v OpenWrt.$(REVISION) \
$(if $(NETGEAR_HW_ID),-H $(NETGEAR_HW_ID)) \
-r "$(1)" \
-i $@ -o $@.new
@@ -83,7 +83,7 @@ define Build/append-uImage-fakeroot-hdr
rm -f $@.fakeroot
$(STAGING_DIR_HOST)/bin/mkimage \
-A $(LINUX_KARCH) -O linux -T filesystem -C none \
- -n '$(call toupper,$(LINUX_KARCH)) LEDE fakeroot' \
+ -n '$(call toupper,$(LINUX_KARCH)) OpenWrt fakeroot' \
-s \
$@.fakeroot
cat $@.fakeroot >> $@
diff --git a/include/image.mk b/include/image.mk
index f4d0a157cd..605cb06672 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -136,7 +136,7 @@ endef
define Image/BuildKernel/MkuImage
mkimage -A $(ARCH) -O linux -T kernel -C $(1) -a $(2) -e $(3) \
- -n '$(call toupper,$(ARCH)) LEDE Linux-$(LINUX_VERSION)' -d $(4) $(5)
+ -n '$(call toupper,$(ARCH)) OpenWrt Linux-$(LINUX_VERSION)' -d $(4) $(5)
endef
define Image/BuildKernel/MkFIT