aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-24 12:40:00 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-24 13:35:45 +0100
commit392cccb7f4189cb8f2f62df467af980b593ce073 (patch)
treecee64224faaf609db8d9228af99f815573cc5e50 /include
parente775adead80869135598b54b5e35e59af67ba6b7 (diff)
downloadupstream-392cccb7f4189cb8f2f62df467af980b593ce073.tar.gz
upstream-392cccb7f4189cb8f2f62df467af980b593ce073.tar.bz2
upstream-392cccb7f4189cb8f2f62df467af980b593ce073.zip
build: remove mips16 feature flag from target makefiles
It can be implicitly derived from the MIPS32 revision support in the kernel configuration Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include')
-rw-r--r--include/target.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index 2e0bf4957d..597563d5ec 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -258,6 +258,9 @@ ifeq ($(DUMP),1)
ifneq ($(CONFIG_VIRTIO),)
FEATURES += virtio
endif
+ ifneq ($(CONFIG_CPU_MIPS32_R2),)
+ FEATURES += mips16
+ endif
FEATURES += $(foreach v,6 7,$(if $(CONFIG_CPU_V$(v)),arm_v$(v)))
# remove duplicates