aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-04-14 19:00:14 +0000
committerJohn Crispin <blogic@openwrt.org>2015-04-14 19:00:14 +0000
commitdcc0f0aacdfbf90c510041063419997ae9ea3d5d (patch)
tree9c36d296610c06bf995ed22267b4a8677a06ded9 /include
parente470997e7c8a346db30b85491b64a697537d7e73 (diff)
downloadupstream-dcc0f0aacdfbf90c510041063419997ae9ea3d5d.tar.gz
upstream-dcc0f0aacdfbf90c510041063419997ae9ea3d5d.tar.bz2
upstream-dcc0f0aacdfbf90c510041063419997ae9ea3d5d.zip
opkg: drop md5 in favour of sha256
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45437 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/image.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/image.mk b/include/image.mk
index 31689c7e6b..165bf72f78 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -258,8 +258,7 @@ endef
define Image/Checksum
( cd ${BIN_DIR} ; \
- $(FIND) -maxdepth 1 -type f \! -name 'md5sums' -printf "%P\n" | sort | xargs \
- md5sum --binary > md5sums \
+ $(FIND) -maxdepth 1 -type f \! -name 'md5sums' -printf "%P\n" | sort | xargs $1 > $2 \
)
endef
@@ -461,6 +460,7 @@ define BuildImage
$(call Image/Build,$(fs))
)
$(call Image/mkfs/ubifs)
- $(call Image/Checksum)
+ $(call Image/Checksum,md5sum --binary,md5sums)
+ $(call Image/Checksum,openssl dgst -sha256,sha256sums)
endef