aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-03-07 17:32:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-03-07 17:32:29 +0000
commitcf3d83fe4a758c9fc0dc2e575b90c77f4fe18df8 (patch)
treee8523fabf4000faec51681f5e2c90940f9382291 /include
parentd32fdeb4c0dc838022fc38b50191d482f2cca20c (diff)
downloadupstream-cf3d83fe4a758c9fc0dc2e575b90c77f4fe18df8.tar.gz
upstream-cf3d83fe4a758c9fc0dc2e575b90c77f4fe18df8.tar.bz2
upstream-cf3d83fe4a758c9fc0dc2e575b90c77f4fe18df8.zip
build: BSD compile fixes
following patch allows to build images for Qemu ARM on OpenBSD 5.2 amd64 and FreeBSD 9.1 amd64. Mostly small pieces of code changes to get things right on the specific platform. Updated the README to describe better, which tools on the host are required. Added some kind of prepare scripts to install needed tools on BSD via packages. Signed-off-by: Waldemar Brodkorb <mail@waldemar-brodkorb.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35900 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/host-build.mk2
-rw-r--r--include/host.mk3
-rw-r--r--include/prereq-build.mk8
3 files changed, 7 insertions, 6 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 320e74ee47..126671a0b3 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -71,7 +71,7 @@ HOST_CONFIGURE_ARGS = \
HOST_MAKE_FLAGS =
-HOST_CONFIGURE_CMD = ./configure
+HOST_CONFIGURE_CMD = $(BASH) ./configure
ifneq ($(HOST_OS),Darwin)
ifeq ($(CONFIG_BUILD_STATIC_TOOLS),y)
diff --git a/include/host.mk b/include/host.mk
index 9b8a32b672..b44c1bf1ac 100644
--- a/include/host.mk
+++ b/include/host.mk
@@ -62,6 +62,9 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
PATCH=`which gpatch 2>/dev/null`; \
[ -n "$$PATCH" -a -x "$$PATCH" ] || PATCH=`which patch 2>/dev/null`; \
echo "PATCH:=$$PATCH" >> $@; \
+ PYTHON=`which python2.7 2>/dev/null`; \
+ [ -n "$$PYTHON" -a -x "$$PYTHON" ] || PYTHON=`which python 2>/dev/null`; \
+ echo "PYTHON:=$$PYTHON" >> $@; \
)
endif
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index c7d59f1202..59ea7ef9a7 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -39,6 +39,8 @@ $(eval $(call Require,case-sensitive-fs, \
))
define Require/getopt
+ gnugetopt --help 2>&1 | grep long >/dev/null || \
+ /usr/local/bin/getopt --help 2>&1 | grep long >/dev/null || \
getopt --help 2>&1 | grep long >/dev/null
endef
$(eval $(call Require,getopt, \
@@ -134,15 +136,11 @@ $(eval $(call RequireCommand,bzip2, \
Please install bzip2. \
))
-$(eval $(call RequireCommand,patch, \
- Please install patch. \
-))
-
$(eval $(call RequireCommand,perl, \
Please install perl. \
))
-$(eval $(call RequireCommand,python, \
+$(eval $(call RequireCommand,$(PYTHON), \
Please install python. \
))