aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-12-13 21:07:04 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2019-12-23 00:22:07 +0100
commit856ea2bad3b3eac565215c0ac79f37a4ba4cd5b7 (patch)
tree04e6563e9656f70225650876f95238b9554df856 /include
parentfd211e1677fc653feeef6b0b8b8e8659ac274b3c (diff)
downloadupstream-856ea2bad3b3eac565215c0ac79f37a4ba4cd5b7.tar.gz
upstream-856ea2bad3b3eac565215c0ac79f37a4ba4cd5b7.tar.bz2
upstream-856ea2bad3b3eac565215c0ac79f37a4ba4cd5b7.zip
libcxx: Add package
Currently in OpenWrt, there are two libc++: libstdcpp and uClibc++. The former is huge and the latter supports only C++98 with some basic support for C++11. Those C++ versions seem to be specific to the compiler version libcxx supports C++11 and above while being much smaller than libstdcpp. On mt7621, these are the sizes of the ipks that I get: libstdcpp: 460786 libcxx: 182881 uClibc++:67720 libcxx is faster than uClibc++ and is under active development as part of the LLVM project while uClibc++ is effectively dead. This PR modifies uclibc++.mk to expose the make menuconfig option. Further cleanup is beyond the scope of this PR. What that means is, this is not used by default. A g++-libcxx wrapper based on the uClibc++ one was added. Works the same way. Compile tested with all packages that use uclibc++.mk in their Makefiles under mipsel_24kc. kismet fails compilation but that package needs to be cleaned up and updated. Runtime tested with gddrescue, gdisk, dcwapd, bonnie++, and aircrack-ng on a TP-Link Archer C7v2. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'include')
-rw-r--r--include/uclibc++.mk12
1 files changed, 10 insertions, 2 deletions
diff --git a/include/uclibc++.mk b/include/uclibc++.mk
index a1a61f26d4..27533279c9 100644
--- a/include/uclibc++.mk
+++ b/include/uclibc++.mk
@@ -4,8 +4,8 @@ ifndef DUMP
endif
endif
-PKG_PREPARED_DEPENDS += CONFIG_USE_UCLIBCXX
-CXX_DEPENDS = +USE_UCLIBCXX:uclibcxx +USE_LIBSTDCXX:libstdcpp
+PKG_PREPARED_DEPENDS += CONFIG_USE_UCLIBCXX CONFIG_USE_LIBCXX
+CXX_DEPENDS = +USE_UCLIBCXX:uclibcxx +USE_LIBCXX:libcxx +USE_LIBSTDCXX:libstdcpp
ifneq ($(CONFIG_USE_UCLIBCXX),)
ifneq ($(CONFIG_CCACHE),)
@@ -14,3 +14,11 @@ ifneq ($(CONFIG_USE_UCLIBCXX),)
TARGET_CXX=g++-uc
endif
endif
+
+ifneq ($(CONFIG_USE_LIBCXX),)
+ ifneq ($(CONFIG_CCACHE),)
+ TARGET_CXX_NOCACHE=g++-libcxx
+ else
+ TARGET_CXX=g++-libcxx
+ endif
+endif