aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-03-28 22:07:28 +0000
committerPetr Štetiar <ynezz@true.cz>2019-06-25 14:12:22 +0000
commit83d9fb0a99e1a177a442a7ed8cd996309dda2083 (patch)
tree7e515d61b1bf99f884922631981f9bcee3b801c9 /include
parent97833a57eff148508b1dd1515c51fdb0f8619803 (diff)
downloadupstream-83d9fb0a99e1a177a442a7ed8cd996309dda2083.tar.gz
upstream-83d9fb0a99e1a177a442a7ed8cd996309dda2083.tar.bz2
upstream-83d9fb0a99e1a177a442a7ed8cd996309dda2083.zip
build: image: add variable for gzip-ext4-padded-squashfs
This common code could be shared by at least 3 targets (malta, armvirt and x86) so let's factor it out to separate variable. Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'include')
-rw-r--r--include/image.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 3680be2155..f5da4853df 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -298,6 +298,23 @@ define Image/Manifest
$(BIN_DIR)/$(IMG_PREFIX)$(if $(PROFILE_SANITIZED),-$(PROFILE_SANITIZED)).manifest
endef
+define Image/gzip-ext4-padded-squashfs
+
+ define Image/Build/squashfs
+ $(call Image/pad-root-squashfs)
+ endef
+
+ ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
+ define Image/Build/gzip/ext4
+ $(call Image/Build/gzip,ext4)
+ endef
+ define Image/Build/gzip/squashfs
+ $(call Image/Build/gzip,squashfs)
+ endef
+ endif
+
+endef
+
ifdef CONFIG_TARGET_ROOTFS_TARGZ
define Image/Build/targz
$(TAR) -cp --numeric-owner --owner=0 --group=0 --mode=a-s --sort=name \