aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2020-02-29 15:28:44 +0000
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2020-02-29 20:55:37 +0000
commit4d87963381cbf0f8600388b95fdf825ffe04ede7 (patch)
treeea959e0cb6b9c2547da7465357ea2674061af1db /include
parent1c880f23248c71a34ee07e1f854d5b6167c85f2d (diff)
downloadupstream-4d87963381cbf0f8600388b95fdf825ffe04ede7.tar.gz
upstream-4d87963381cbf0f8600388b95fdf825ffe04ede7.tar.bz2
upstream-4d87963381cbf0f8600388b95fdf825ffe04ede7.zip
build: add xargs as prerequisite
Build system needs an 'xargs' that supports '-r' which darwin doesn't. Homebrew installs a 'gxargs' with the findutils package so look for 'gxargs' as well as 'xargs' This is a bit of a 'fun' corner case anyway. xargs is only required by the build if 'CONFIG_AUTOREMOVE' is set and after the build system has built 'tools/findutils' we have a fully working xargs for host anyway. Until that time we have to rely on the host's xargs implementation. Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Diffstat (limited to 'include')
-rw-r--r--include/prereq-build.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index a711ae33f7..6fec4c1a4a 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -93,6 +93,11 @@ $(eval $(call SetupHostCommand,find,Please install GNU 'find', \
$(eval $(call SetupHostCommand,bash,Please install GNU 'bash', \
bash --version 2>&1 | grep GNU))
+$(eval $(call SetupHostCommand,xargs, \
+ Please install 'xargs' that supports '-r/--no-run-if-empty', \
+ gxargs -r --version, \
+ xargs -r --version))
+
$(eval $(call SetupHostCommand,patch,Please install GNU 'patch', \
gpatch --version 2>&1 | grep 'Free Software Foundation', \
patch --version 2>&1 | grep 'Free Software Foundation'))