aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-19 06:38:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-19 06:38:06 +0000
commit47c25a1e96577f777b34b7e73b4bb70c54290b3f (patch)
tree2f2479922428451a64e2db3e1cff48354b95f2be /include
parent2665d7f09e8f1b23744fd19243b2747f654e4656 (diff)
downloadupstream-47c25a1e96577f777b34b7e73b4bb70c54290b3f.tar.gz
upstream-47c25a1e96577f777b34b7e73b4bb70c54290b3f.tar.bz2
upstream-47c25a1e96577f777b34b7e73b4bb70c54290b3f.zip
fix unnecessary kernel package recompile
SVN-Revision: 5227
Diffstat (limited to 'include')
-rw-r--r--include/package.mk22
1 files changed, 12 insertions, 10 deletions
diff --git a/include/package.mk b/include/package.mk
index 05b4ffd2dc..b4f16e2d3a 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -256,16 +256,18 @@ define BuildPackage
$$(eval $$(call Build/DefaultTargets,$(1)))
- ifneq ($$(CONFIG_PACKAGE_$(1)),)
- ifneq ($(MAKECMDGOALS),prereq)
- ifneq ($(DUMP),1)
- ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install '$$(IPKG_$(1))' '$(PKG_BUILD_DIR)'),$$(IPKG_$(1)))
- _INFO+=$(subst $(TOPDIR)/,,$$(IPKG_$(1)))
- $(PKG_BUILD_DIR)/.built: package-rebuild
- endif
-
- ifneq ($$(_INFO),)
- $$(info Rebuilding $$(_INFO))
+ ifdef Package/$(1)/install
+ ifneq ($$(CONFIG_PACKAGE_$(1)),)
+ ifneq ($(MAKECMDGOALS),prereq)
+ ifneq ($(DUMP),1)
+ ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install '$$(IPKG_$(1))' '$(PKG_BUILD_DIR)'),$$(IPKG_$(1)))
+ _INFO+=$(subst $(TOPDIR)/,,$$(IPKG_$(1)))
+ $(PKG_BUILD_DIR)/.built: package-rebuild
+ endif
+
+ ifneq ($$(_INFO),)
+ $$(info Rebuilding $$(_INFO))
+ endif
endif
endif
endif