aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorXu Wang <xwang1498@gmx.com>2020-01-06 17:12:43 +0000
committerJo-Philipp Wich <jo@mein.io>2020-01-14 17:52:34 +0100
commit44304c1d671696ed9598735e71a1635276102511 (patch)
tree750b7c98a45b6ce1236e67c3735931bb2b3ccf77 /include
parent3c77e4ae4d97ec14daeabfab12ec8b451184d0d6 (diff)
downloadupstream-44304c1d671696ed9598735e71a1635276102511.tar.gz
upstream-44304c1d671696ed9598735e71a1635276102511.tar.bz2
upstream-44304c1d671696ed9598735e71a1635276102511.zip
base-files: fix build for /sbin/pkg_check
Setting CONFIG_IPK_FILES_CHECKSUMS=y causes sha256 checksum files to be included with the packages to check for corruption. This commit fixes two issues: - /sbin/pkg_check was being removed incorrectly if IPK_FILES_CHECKSUMS=y - checksums were being saved in the wrong file Signed-off-by: Xu Wang <xwang1498@gmx.com>
Diffstat (limited to 'include')
-rw-r--r--include/package-ipkg.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 442d3854f0..c4c8f4a36f 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -207,7 +207,7 @@ $(_endef)
(cd $$(IDIR_$(1)); \
( \
find . -type f \! -path ./CONTROL/\* -exec sha256sum \{\} \; 2> /dev/null | \
- sed 's|\([[:blank:]]\)\./|\1/|' > $$(IDIR_$(1))/CONTROL/files-sha256 \
+ sed 's|\([[:blank:]]\)\./|\1/|' > $$(IDIR_$(1))/CONTROL/files-sha256sum \
) || true \
)
endif