aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-01-22 23:10:57 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-01-22 23:10:57 +0000
commit42e4f83096b9670f5fcc19919f12dd564a94247b (patch)
tree38d0056bef5026974f51557b306b1f3161cfa1b4 /include
parentad8700a22a5f0f6c5c3be7c998141e1da3ed916a (diff)
downloadupstream-42e4f83096b9670f5fcc19919f12dd564a94247b.tar.gz
upstream-42e4f83096b9670f5fcc19919f12dd564a94247b.tar.bz2
upstream-42e4f83096b9670f5fcc19919f12dd564a94247b.zip
fix rootfs preparation with rootfs containing files with whitespaces in the filename (based on patch from #6551)
SVN-Revision: 19282
Diffstat (limited to 'include')
-rw-r--r--include/image.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/image.mk b/include/image.mk
index ac80937049..990ce8e400 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -126,9 +126,9 @@ endif
define Image/mkfs/prepare/default
- - find $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' | $(XARGS) chmod 0644
- - find $(TARGET_DIR) -type f -perm +0100 | $(XARGS) chmod 0755
- - find $(TARGET_DIR) -type d | $(XARGS) chmod 0755
+ - $(FIND) $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' -print0 | $(XARGS) -0 chmod 0644
+ - $(FIND) $(TARGET_DIR) -type f -perm +0100 -print0 | $(XARGS) -0 chmod 0755
+ - $(FIND) $(TARGET_DIR) -type d -print0 | $(XARGS) -0 chmod 0755
$(INSTALL_DIR) $(TARGET_DIR)/tmp
chmod 0777 $(TARGET_DIR)/tmp
endef