aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2019-10-10 13:42:56 +0200
committerFelix Fietkau <nbd@nbd.name>2019-10-10 13:55:23 +0200
commitfcf87d5461c56091313a9432472264c8da8574e3 (patch)
tree113905220d04c22edf33955f77c56f92dee08205 /include
parent53a6aa5164713c74570c4fbd28d56a75137dd00d (diff)
downloadupstream-fcf87d5461c56091313a9432472264c8da8574e3.tar.gz
upstream-fcf87d5461c56091313a9432472264c8da8574e3.tar.bz2
upstream-fcf87d5461c56091313a9432472264c8da8574e3.zip
build: adjust gcc/g++ version checks for newer apple compilers
Signed-off-by: Felix Fietkau <nbd@nbd.name> (cherry-picked from commit 46a129194de0f9e2f71b6526634569e1ec802504)
Diffstat (limited to 'include')
-rw-r--r--include/prereq-build.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index f7da916f64..cbfc62397e 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -37,7 +37,7 @@ $(eval $(call SetupHostCommand,gcc, \
gcc7 --version | grep gcc, \
gcc8 --version | grep gcc, \
gcc9 --version | grep gcc, \
- gcc --version | grep Apple.LLVM ))
+ gcc --version | grep -E 'Apple.(LLVM|clang)' ))
$(eval $(call TestHostCommand,working-gcc, \
\nPlease reinstall the GNU C Compiler (4.8 or later) - \
@@ -56,7 +56,7 @@ $(eval $(call SetupHostCommand,g++, \
g++7 --version | grep g++, \
g++8 --version | grep g++, \
g++9 --version | grep g++, \
- g++ --version | grep Apple.LLVM ))
+ g++ --version | grep -E 'Apple.(LLVM|clang)' ))
$(eval $(call TestHostCommand,working-g++, \
\nPlease reinstall the GNU C++ Compiler (4.8 or later) - \