aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2018-12-04 14:47:23 +0100
committerJo-Philipp Wich <jo@mein.io>2019-09-04 13:32:36 +0200
commitfb99be49f970aaa29da86e2edc2b82dcd421e7dd (patch)
tree7ba75af3b4ce64f0c41f60c68bcc5e56a0444443 /include
parent04413f7612076a9f6bf713b31ead8b4396845ebb (diff)
downloadupstream-fb99be49f970aaa29da86e2edc2b82dcd421e7dd.tar.gz
upstream-fb99be49f970aaa29da86e2edc2b82dcd421e7dd.tar.bz2
upstream-fb99be49f970aaa29da86e2edc2b82dcd421e7dd.zip
autotools.mk: autoreconf: fix missing install-sh
I'm trying to create a package for libgpiod, which uses AC_CONFIG_AUX_DIR macro, which is probably leading to the following configure error: autoreconf: running: /openwrt.git/staging_dir/host/bin/libtoolize --force OpenWrt-libtoolize: putting auxiliary files in AC_CONFIG_AUX_DIR, `autostuff'. OpenWrt-libtoolize: linking file `autostuff/ltmain.sh' OpenWrt-libtoolize: putting macros in `m4'. ... configure: error: cannot find install-sh, install.sh, or shtool in autostuff "."/autostuff >From the build output it's clear, that libtoolize isn't installing install-sh symlink, because libtoolize would install install-sh only if it's being run with --install parameter. Corresponding part in libtoolize: if $opt_install; then func_config_update config.guess \ "$pkgdatadir/config" "$auxdir" pkgconfig_header func_config_update config.sub \ "$pkgdatadir/config" "$auxdir" pkgconfig_header func_install_update install-sh \ "$pkgdatadir/config" "$auxdir" pkgconfig_header fi func_ltmain_update ltmain.sh \ "$pkgdatadir/config" "$auxdir" pkgconfig_header Adding --install parameter to libtoolize fixes this build issue: autoreconf: running: /openwrt.git/staging_dir/host/bin/libtoolize --install --force OpenWrt-libtoolize: putting auxiliary files in AC_CONFIG_AUX_DIR, `autostuff'. OpenWrt-libtoolize: linking file `autostuff/config.guess' OpenWrt-libtoolize: linking file `autostuff/config.sub' OpenWrt-libtoolize: linking file `autostuff/install-sh' OpenWrt-libtoolize: linking file `autostuff/ltmain.sh' OpenWrt-libtoolize: putting macros in `m4'. Cc: Felix Fietkau <nbd@nbd.name> Signed-off-by: Petr Štetiar <ynezz@true.cz> (cherry picked from commit 5cf897779eacf63cdbcdebd1af68c109096665c6)
Diffstat (limited to 'include')
-rw-r--r--include/autotools.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index aa044aa0b4..ae320fbde0 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -39,7 +39,9 @@ define autoreconf
[ -e $(p)/config.rpath ] || \
ln -s $(SCRIPT_DIR)/config.rpath $(p)/config.rpath; \
touch NEWS AUTHORS COPYING ABOUT-NLS ChangeLog; \
- $(AM_TOOL_PATHS) $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
+ $(AM_TOOL_PATHS) \
+ LIBTOOLIZE='$(STAGING_DIR_HOST)/bin/libtoolize --install' \
+ $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
$(if $(word 2,$(3)),--no-recursive) \
-B $(STAGING_DIR_HOST)/share/aclocal \
$(patsubst %,-I %,$(5)) \