aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-11-17 13:42:04 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2019-12-23 00:31:48 +0100
commitdf45ef54368d3e4f872928f47edc424d843b120d (patch)
treefe6da02325667767b09ce8563f5452cd1caf9038 /include
parent6351205d7354117a9336fe4150ad264eb93f72e7 (diff)
downloadupstream-df45ef54368d3e4f872928f47edc424d843b120d.tar.gz
upstream-df45ef54368d3e4f872928f47edc424d843b120d.tar.bz2
upstream-df45ef54368d3e4f872928f47edc424d843b120d.zip
cmake: Install host packages to lib instead of lib64
Several CMake packages such as log4cplus and protobuf(-c) install to lib64 instead of lib on some hosts. This completely breaks rpath linking. Override it globally to avoid fixing each package individually. Signed-off-by: Rosen Penev <rosenp@gmail.com> Tested-by: Sebastian Kemper <sebastian_ml@gmx.net> (cherry picked from commit 383abffb1179a142b4c8f86559baad5b24d391c3)
Diffstat (limited to 'include')
-rw-r--r--include/cmake.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/cmake.mk b/include/cmake.mk
index b66665d20a..a5ba7d31bf 100644
--- a/include/cmake.mk
+++ b/include/cmake.mk
@@ -103,6 +103,7 @@ define Host/Configure/Default
-DCMAKE_INSTALL_PREFIX=$(HOST_BUILD_PREFIX) \
-DCMAKE_PREFIX_PATH=$(HOST_BUILD_PREFIX) \
-DCMAKE_SKIP_RPATH=TRUE \
+ -DCMAKE_INSTALL_LIBDIR=lib \
$(CMAKE_HOST_OPTIONS) \
$(HOST_CMAKE_SOURCE_DIR) \
)