aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJonas Gorski <jonas.gorski@gmail.com>2019-06-22 14:02:27 +0200
committerJo-Philipp Wich <jo@mein.io>2019-09-04 13:21:22 +0200
commitbdd1bf8b8936a83edb151a429983ed28069f5f95 (patch)
tree87050808dbee598a9a5b1ec673d1478a978938b1 /include
parentc71f70fcdde2584d460b0695b99bfd7c4e1c759b (diff)
downloadupstream-bdd1bf8b8936a83edb151a429983ed28069f5f95.tar.gz
upstream-bdd1bf8b8936a83edb151a429983ed28069f5f95.tar.bz2
upstream-bdd1bf8b8936a83edb151a429983ed28069f5f95.zip
build: warn when packages have no associated install section
Declaring a package without the appropriate install section is an easy mistake to make, especially when renaming packages. Since this is also easy to detect, warn about it when it happens. Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com> No-objections-at-all-by: Jo-Philipp Wich <jo@mein.io> (cherry picked from commit 5ede3fcdf74dcc1b1b4c9415152b2e8b26a45ead)
Diffstat (limited to 'include')
-rw-r--r--include/package-ipkg.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 38252b95cd..442d3854f0 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -124,6 +124,8 @@ ifeq ($(DUMP),)
endif
$(PKG_INSTALL_STAMP).$(1): prepare-package-install
echo "$(1)" >> $(PKG_INSTALL_STAMP)
+ else
+ $(if $(CONFIG_PACKAGE_$(1)),$$(warning WARNING: skipping $(1) -- package has no install section))
endif
endif