aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-16 14:09:57 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-16 14:09:57 +0000
commitac2af6affae6e73279347336dea1b8d7e76d84d5 (patch)
tree8ef85000fe57eb93eb6b7479033e05506d98054a /include
parent420f252a5863918a22403deea89813d73b3b1e90 (diff)
downloadupstream-ac2af6affae6e73279347336dea1b8d7e76d84d5.tar.gz
upstream-ac2af6affae6e73279347336dea1b8d7e76d84d5.tar.bz2
upstream-ac2af6affae6e73279347336dea1b8d7e76d84d5.zip
allow targets for override generic config (GENERIC_LINUX_CONFIG:=/dev/null) for testing purposes
SVN-Revision: 8796
Diffstat (limited to 'include')
-rw-r--r--include/target.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/target.mk b/include/target.mk
index 8f072d0cd8..c8eb76c254 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -87,7 +87,7 @@ include $(INCLUDE_DIR)/kernel-version.mk
GENERIC_PLATFORM_DIR := $(TOPDIR)/target/linux/generic-$(KERNEL)
GENERIC_PATCH_DIR := $(GENERIC_PLATFORM_DIR)/patches$(shell [ -d "$(GENERIC_PLATFORM_DIR)/patches-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
-GENERIC_LINUX_CONFIG:=$(firstword $(wildcard $(GENERIC_PLATFORM_DIR)/config-$(KERNEL_PATCHVER) $(GENERIC_PLATFORM_DIR)/config-default))
+GENERIC_LINUX_CONFIG?=$(firstword $(wildcard $(GENERIC_PLATFORM_DIR)/config-$(KERNEL_PATCHVER) $(GENERIC_PLATFORM_DIR)/config-default))
LINUX_CONFIG?=$(firstword $(wildcard $(foreach subdir,$(PLATFORM_DIR) $(PLATFORM_SUBDIR),$(subdir)/config-$(KERNEL_PATCHVER) $(subdir)/config-default)))
LINUX_SUBCONFIG?=$(firstword $(wildcard $(PLATFORM_SUBDIR)/config-$(KERNEL_PATCHVER) $(PLATFORM_SUBDIR)/config-default))
ifeq ($(LINUX_CONFIG),$(LINUX_SUBCONFIG))