aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-08 20:04:43 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-08 20:04:43 +0000
commit87a88cebc798989ef7d36cc590d4a3cdd42134f0 (patch)
tree86f5d6cdd464f9cc8a791001fc4d29eb714522eb /include
parenta9d683ca912b2c4837b2e65909c09ca01babe3df (diff)
downloadupstream-87a88cebc798989ef7d36cc590d4a3cdd42134f0.tar.gz
upstream-87a88cebc798989ef7d36cc590d4a3cdd42134f0.tar.bz2
upstream-87a88cebc798989ef7d36cc590d4a3cdd42134f0.zip
adapt profiles for subtarget changes
SVN-Revision: 8695
Diffstat (limited to 'include')
-rw-r--r--include/target.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/include/target.mk b/include/target.mk
index 42f484af9d..8f072d0cd8 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -70,13 +70,17 @@ define Profile
getvar "$(call shvar,Profile/$(1)/Description)"; \
echo "@@"; \
echo;
- ifeq ($(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(if $(2),$(2)_)$(1))),y)
+ ifeq ($(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(if $(SUBTARGET),$(SUBTARGET)_)$(1))),y)
PROFILE=$(1)
endif
endef
-$(eval $(call shexport,Target/Description))
+-include $(PLATFORM_DIR)/profiles/*.mk
+ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
+ -include $(PLATFORM_SUBDIR)/profiles/*.mk
+endif
+$(eval $(call shexport,Target/Description))
include $(INCLUDE_DIR)/kernel-version.mk