aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJonas Gorski <jonas.gorski@gmail.com>2019-09-06 14:55:36 +0200
committerJo-Philipp Wich <jo@mein.io>2019-09-08 18:50:11 +0200
commit4c8258c925a0cd6a4738b9eed7cd503c1873e88f (patch)
tree8c0b45a34326c3fc3764a7d65311469446ebba65 /include
parent271990321abee4c50802f87f32065ced0ce57764 (diff)
downloadupstream-4c8258c925a0cd6a4738b9eed7cd503c1873e88f.tar.gz
upstream-4c8258c925a0cd6a4738b9eed7cd503c1873e88f.tar.bz2
upstream-4c8258c925a0cd6a4738b9eed7cd503c1873e88f.zip
Revert "build: remove harmful -nopad option from mksquashfs"
This reverts commit 1c0290c5cc6258c48b8ba46b4f9c85a21de4f875. Dropping the nopad can make the padding overflow into the next erase block on devices using a non-aligned rootfs start. This breaks the jffs2 overlay partition with the following messages: [ 30.343877] jffs2_scan_eraseblock(): End of filesystem marker found at 0x10000 [ 30.376512] jffs2: Cowardly refusing to erase blocks on filesystem with no valid JFFS2 nodes [ 30.385253] jffs2: empty_blocks 196, bad_blocks 0, c->nr_blocks 197 Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com> (cherry picked from commit f11d90a76b719106336b94d85b166b4ebf19dbb0)
Diffstat (limited to 'include')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index b4da926cf5..1538d83df3 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -227,7 +227,7 @@ $(eval $(foreach S,$(NAND_BLOCKSIZE),$(call Image/mkfs/jffs2-nand/template,$(S))
define Image/mkfs/squashfs
$(STAGING_DIR_HOST)/bin/mksquashfs4 $(call mkfs_target_dir,$(1)) $@ \
- -noappend -root-owned \
+ -nopad -noappend -root-owned \
-comp $(SQUASHFSCOMP) $(SQUASHFSOPT) \
-processors 1
endef