aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-11-18 18:15:56 +0100
committerYousong Zhou <yszhou4tech@gmail.com>2019-10-24 10:28:51 +0000
commitdff0b2104d8403f888c3d0bebd70dce08d254dad (patch)
tree5388be092bc268d830e44808eaaab31b357f2b52 /include
parent3b8db97a528e72de2d162af71e912ff81c1ef1a3 (diff)
downloadupstream-dff0b2104d8403f888c3d0bebd70dce08d254dad.tar.gz
upstream-dff0b2104d8403f888c3d0bebd70dce08d254dad.tar.bz2
upstream-dff0b2104d8403f888c3d0bebd70dce08d254dad.zip
kernel: netfilter: Add nf_tproxy_ipv{4,6} and nf_socket_ipv{4,6}
The nf_socket.ko module was split in commit 8db4c5be88f ("netfilter: move socket lookup infrastructure to nf_socket_ipv{4,6}.c") into a common, n IPv4 and an IPv6 part. The nf_tproxy.ko module was split in commit 45ca4e0cf27 ("netfilter: Libify xt_TPROXY") into a common, an IPv4 and an IPv6 part. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> (cherry picked from commit 89806545cc1711f4e33c1c2ac5265aec4afe8078) (required for fixing FS#2531) Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'include')
-rw-r--r--include/netfilter.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 510aa183ca..2a4f89472c 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -258,7 +258,11 @@ $(eval $(call nf_add,IPT_DEBUG,CONFIG_NETFILTER_XT_TARGET_TRACE, $(P_XT)xt_TRACE
# tproxy
$(eval $(call nf_add,IPT_TPROXY,CONFIG_NETFILTER_XT_MATCH_SOCKET, $(P_XT)xt_socket))
+$(eval $(call nf_add,IPT_TPROXY,CONFIG_NF_SOCKET_IPV4, $(P_V4)nf_socket_ipv4, ge 4.10))
+$(eval $(call nf_add,IPT_TPROXY,CONFIG_NF_SOCKET_IPV6, $(P_V6)nf_socket_ipv6, ge 4.10))
$(eval $(call nf_add,IPT_TPROXY,CONFIG_NETFILTER_XT_TARGET_TPROXY, $(P_XT)xt_TPROXY))
+$(eval $(call nf_add,IPT_TPROXY,CONFIG_NF_TPROXY_IPV4, $(P_V4)nf_tproxy_ipv4, ge 4.18))
+$(eval $(call nf_add,IPT_TPROXY,CONFIG_NF_TPROXY_IPV6, $(P_V6)nf_tproxy_ipv6, ge 4.18))
# led
$(eval $(call nf_add,IPT_LED,CONFIG_NETFILTER_XT_TARGET_LED, $(P_XT)xt_LED))