aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorEtienne Champetier <champetier.etienne@gmail.com>2019-10-31 03:54:59 -0700
committerPetr Štetiar <ynezz@true.cz>2019-11-09 08:26:14 +0100
commitdfd8c3bfdccfde7b84735aafd7b2c69cc4d9b087 (patch)
tree8d6d70e24eddabb8b62e979504182724aedae72d /include
parent69bc68b46ba0518c3d2eefa966badac967fc3e35 (diff)
downloadupstream-dfd8c3bfdccfde7b84735aafd7b2c69cc4d9b087.tar.gz
upstream-dfd8c3bfdccfde7b84735aafd7b2c69cc4d9b087.tar.bz2
upstream-dfd8c3bfdccfde7b84735aafd7b2c69cc4d9b087.zip
build: fixup python SetupHostCommand to use python2
Here is a way to break your build env without this patch: 1) have python point to python3, and no python2 2) start the build, SetupHostCommand will create a symlink ./staging_dir/host/bin/python -> /usr/bin/python 3) build fails on scons because it can't find any python2 4) install python2 and restart the build 5) the build fails on wireless-regdb compile because python is python3 instead of python Signed-off-by: Etienne Champetier <champetier.etienne@gmail.com> (cherry picked from commit 785d4f3efded4a5094ee8e1ce4535dd0933b956d)
Diffstat (limited to 'include')
-rw-r--r--include/prereq-build.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index f7da916f64..209392b720 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -142,9 +142,9 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
perl --version | grep "perl.*v5"))
$(eval $(call SetupHostCommand,python,Please install Python 2.x, \
- python2.7 -V 2>&1 | grep Python, \
- python2 -V 2>&1 | grep Python, \
- python -V 2>&1 | grep Python))
+ python2.7 -V 2>&1 | grep 'Python 2.7', \
+ python2 -V 2>&1 | grep 'Python 2', \
+ python -V 2>&1 | grep 'Python 2'))
$(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule))