aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-09-04 14:44:10 +0000
committerJonas Gorski <jogo@openwrt.org>2015-09-04 14:44:10 +0000
commitdb8ae81f898feea640d7a1d9e15215dfd01ff208 (patch)
tree8bbd10c67898d9e78cc2eb5d3f16af905ee47a90 /include
parent556d483a6fff31bc6d9f469b5281de2b2751ddd3 (diff)
downloadupstream-db8ae81f898feea640d7a1d9e15215dfd01ff208.tar.gz
upstream-db8ae81f898feea640d7a1d9e15215dfd01ff208.tar.bz2
upstream-db8ae81f898feea640d7a1d9e15215dfd01ff208.zip
image: add a build step for building and appending an ubinized rootfs
Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46783
Diffstat (limited to 'include')
-rw-r--r--include/image.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 73fc805bb5..fb89ed1222 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -345,6 +345,16 @@ define Build/append-rootfs
dd if=$(word 2,$^) $(if $(1),bs=$(1) conv=sync) >> $@
endef
+define Build/append-ubi
+ sh $(TOPDIR)/scripts/ubinize-image.sh \
+ $(if $(KERNEL_IN_UBI),--kernel $(word 1,$^)) \
+ $(word 2,$^) \
+ $@.tmp \
+ -p $(BLOCKSIZE) -m $(PAGESIZE) -E 5
+ cat $@.tmp >> $@
+ rm $@.tmp
+endef
+
define Build/pad-to
dd if=$@ of=$@.new bs=$(1) conv=sync
mv $@.new $@