aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2018-06-09 09:11:24 +0100
committerJo-Philipp Wich <jo@mein.io>2018-12-18 09:44:04 +0100
commitbecdd2b28e0da5d4cfec6f0d74ce6ac5d04cbb22 (patch)
tree5770107fc27a891f6ceeadb598a369959d6867ca /include
parentf5e33b98394e9293b592d55e7dc29633e7eb20d7 (diff)
downloadupstream-becdd2b28e0da5d4cfec6f0d74ce6ac5d04cbb22.tar.gz
upstream-becdd2b28e0da5d4cfec6f0d74ce6ac5d04cbb22.tar.bz2
upstream-becdd2b28e0da5d4cfec6f0d74ce6ac5d04cbb22.zip
build: ASLR hardening use $(FPIC)
Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk> (backported from 89b59994eb44b5cd2fac594144c20c63fd05ef25)
Diffstat (limited to 'include')
-rw-r--r--include/hardening.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/hardening.mk b/include/hardening.mk
index 06a61789ef..42ce1f56b5 100644
--- a/include/hardening.mk
+++ b/include/hardening.mk
@@ -18,7 +18,7 @@ ifdef CONFIG_PKG_CHECK_FORMAT_SECURITY
endif
ifdef CONFIG_PKG_ASLR_PIE
ifeq ($(strip $(PKG_ASLR_PIE)),1)
- TARGET_CFLAGS += -fPIC
+ TARGET_CFLAGS += $(FPIC)
TARGET_LDFLAGS += -specs=$(INCLUDE_DIR)/hardened-ld-pie.specs
endif
endif