aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2018-07-03 16:15:35 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2018-07-05 01:30:57 +0800
commite48ea13b3bac5393d6400156ddb066ec5de2ea4e (patch)
tree5600319f06a9dde73f7cf608743624b1b1578a04 /include
parenteb6759cc786b9a5fe1425364fc54212a425ff0be (diff)
downloadupstream-e48ea13b3bac5393d6400156ddb066ec5de2ea4e.tar.gz
upstream-e48ea13b3bac5393d6400156ddb066ec5de2ea4e.tar.bz2
upstream-e48ea13b3bac5393d6400156ddb066ec5de2ea4e.zip
download.mk: add more comments
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'include')
-rw-r--r--include/download.mk7
1 files changed, 5 insertions, 2 deletions
diff --git a/include/download.mk b/include/download.mk
index 3634e777c9..5cfc542042 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -59,7 +59,7 @@ check_escape=$(subst ','\'',$(1))
# $(1): suffix of the F_, C_ variables, e.g. hash_deprecated, hash_mismatch, etc.
# $(2): filename
# $(3): expected hash value
-# $(4): hash var name: MD5SUM, HASH
+# $(4): var name of the the form: {PKG_,Download/<name>:}{,MIRROR_}{HASH,MIRROR_HASH}
check_warn_nofix = $(info $(shell printf "$(_R)WARNING: %s$(_N)" '$(call check_escape,$(call C_$(1),$(2),$(3),$(4)))'))
ifndef FIXUP
check_warn = $(check_warn_nofix)
@@ -77,12 +77,15 @@ endif
# $(1): filename
# $(2): expected hash value
-# $(3): hash var name: MD5SUM, HASH
+# $(3): var name of the the form: {PKG_,Download/<name>:}{,MIRROR_}{HASH,MIRROR_HASH}
C_download_missing = $(1) is missing, please run make download before re-running this check
C_hash_mismatch = $(3) does not match $(1) hash $(call gen_sha256sum,$(1))
C_hash_deprecated = $(3) uses deprecated hash, set to $(call gen_sha256sum,$(1))
C_hash_missing = $(3) is missing, set to $(call gen_sha256sum,$(1))
+# $(1): filename
+# $(2): expected hash value
+# $(3): var name of the the form: {PKG_,Download/<name>:}{,MIRROR_}{HASH,MIRROR_HASH}
check_hash = \
$(if $(wildcard $(DL_DIR)/$(1)), \
$(if $(filter-out x,$(2)), \