aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2018-06-29 13:49:34 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2018-06-29 13:54:17 +0800
commite15565a01cea6a61c537f5fb91c4e4d27fb7b290 (patch)
tree9961527995c8e387e33ff6073b5056a6be0a5d8e /include
parentb06c447c5f66fd13078327bda3d885d48e2c0e42 (diff)
downloadupstream-e15565a01cea6a61c537f5fb91c4e4d27fb7b290.tar.gz
upstream-e15565a01cea6a61c537f5fb91c4e4d27fb7b290.tar.bz2
upstream-e15565a01cea6a61c537f5fb91c4e4d27fb7b290.zip
download.mk: restore the old dl_method implementation
Seems like the python download.py dl_method call causes serious performance regression for fresh "make defconfig" as reported in FS#1621. GitHub tarball download will also be disabled with this Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'include')
-rw-r--r--include/download.mk18
1 files changed, 17 insertions, 1 deletions
diff --git a/include/download.mk b/include/download.mk
index 91a22c2316..3634e777c9 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -21,7 +21,23 @@ DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
# Try to guess the download method from the URL
define dl_method
-$(shell $(SCRIPT_DIR)/download.py dl_method --url $(foreach url,$(1),"$(url)") --proto="$(2)")
+$(strip \
+ $(if $(2),$(2), \
+ $(if $(filter @APACHE/% @GITHUB/% @GNOME/% @GNU/% @KERNEL/% @SF/% @SAVANNAH/% ftp://% http://% https://% file://%,$(1)),default, \
+ $(if $(filter git://%,$(1)),git, \
+ $(if $(filter svn://%,$(1)),svn, \
+ $(if $(filter cvs://%,$(1)),cvs, \
+ $(if $(filter hg://%,$(1)),hg, \
+ $(if $(filter sftp://%,$(1)),bzr, \
+ unknown \
+ ) \
+ ) \
+ ) \
+ ) \
+ ) \
+ ) \
+ ) \
+)
endef
# code for creating tarballs from cvs/svn/git/bzr/hg/darcs checkouts - useful for mirror support